SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiling Cufflinks 2.1.1: Fatal error sindrle Bioinformatics 5 09-05-2014 04:41 AM
Cufflinks make Error (differential.o failed) Sebastiano Bioinformatics 4 07-01-2013 11:42 AM
Cufflinks refuses to operate on Tophat2 created bam or sam files due to sorting error amrezans Bioinformatics 1 06-24-2013 12:54 PM
Compiling Cufflinks 2.0.2 with gcc 4.7 rwan Bioinformatics 1 02-17-2013 08:25 AM
Compiling cufflinks 0.9.x seqmagician Bioinformatics 9 10-27-2010 06:31 AM

Reply
 
Thread Tools
Old 03-16-2015, 02:44 AM   #1
kristianunger
Junior Member
 
Location: Munich, Germany

Join Date: Mar 2015
Posts: 1
Default compiling of cufflinks failed due to bamlib error

Hi there,

I know this issue has been addressed already in the instructions and also in some other forums. However, since I don't get it resolved after spending loads of time I hope someone can help me sorting out my problem:

I am trying to compile the latest version of cufflinks (2.2.1) according to instructions given here http://cole-trapnell-lab.github.io/c...tting_started/ but I end up with the error

checking for bamlib... configure: error: We could not detect the bam libraries (version or higher). If you have a staged bam library (still not installed) please specify $BAM_ROOT in your environment and do not give a PATH to --with-bam option. If you are sure you have bam installed, then check your version number looking in <bam/version.hpp>. See http://randspringer.de/bam for more documentation.

From the instructions and having a look into the configure file I understand that in the first place the standard location /usr/local is searched for the samtools files which have to be organised as follows


/usr/local/include/bam #has to contain the header files *.h
/usr/local/lib #has to contain libbam.a

and the samtools binary needs to go somewhere in $PATH .

Since I only can do local installations I generated a folder in my home /home/group/user/:

/home/group/user/bin/samtools

and set up the structure described above:

/home/group/user/bin/samtools
/home/group/user/bin/samtools/lib containing the libbam.a file
/home/group/user/bin/samtools/include/bam containing all the header files

then added the directory to PATH by:

export PATH=$PATH:/home/group/user/bin/samtools

and executed configure using

./configure --prefix=/home/group/user/cufflinks/src/ --with-eigen=/home/group/user/Eigen/

and get the following output:

bash-4.2$ ./configure --prefix=/home/group/user/cufflinks/src/ --with-eigen=/home/group/user/Eigen/
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gawk... (cached) gawk
checking for g++... g++
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking whether make sets $(MAKE)... (cached) yes
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking for a Python interpreter with version >= 2.4... python
checking for python... /usr/bin/python
checking for python version... 2.7
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.7/site-packages
checking for python extension module directory... ${exec_prefix}/lib64/python2.7/site-packages
checking for boostlib >= 1.47.0... yes
checking for bamlib... configure: error: We could not detect the bam libraries (version or higher). If you have a staged bam library (still not installed) please specify $BAM_ROOT in your environment and do not give a PATH to --with-bam option. If you are sure you have bam installed, then check your version number looking in <bam/version.hpp>. See http://randspringer.de/bam for more documentation.

I really tried everything suggested in the forums such setting the BAM_ROOT variable but I cannot work out what the problem is!

Can you please help? I am sure there is something stupid I am missing and and blind for after countless times of trying...

Many thanks!

Kristian
kristianunger is offline   Reply With Quote
Old 03-17-2015, 08:06 AM   #2
[email protected]
Junior Member
 
Location: Western MA

Join Date: Mar 2015
Posts: 3
Default

I am having the same issues, installing at root, even after following instructions I found for dealing with the problem. I also tried installing with homebrew and got the same error:

Quote:
==> ./configure --prefix=/usr/local/Cellar/cufflinks/2.2.1 --mandir=/usr/local/Cellar/cufflinks/2.2.
checking for python platform... darwin
checking for python script directory... ${prefix}/lib/python2.7/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.7/site-packages
checking for boostlib >= 1.47.0... yes
checking for bamlib... configure: error: We could not detect the bam libraries (version or higher). If you have a staged bam library (still not installed) please specify $BAM_ROOT in your environment and do not give a PATH to --with-bam option. If you are sure you have bam installed, then check your version number looking in <bam/version.hpp>. See http://randspringer.de/bam for more documentation.
Any help would be hugely appreciated!
jgrant@smith.edu is offline   Reply With Quote
Old 03-19-2015, 01:22 AM   #3
sklages
Senior Member
 
Location: Berlin, DE

Join Date: May 2008
Posts: 620
Default

Installing current samtools already results in a "correct" directory structure with 'include', 'lib' etc.

1) put samtools in bin or install current samtools and export path to
Quote:
export /path/to/samtools/bin:$PATH
2) configure, pointing to lib dir,
Quote:
export CPPFLAGS="-I/path/to/eigen/include/eigen3"

./configure --prefix=/path/to/cufflinks/2.2.1 --with-boost=/path/to/boost --with-bam=/path/to/samtools/lib --with-eigen=/path/to/eigen
Quote:
[...]
checking for boostlib >= 1.47.0... yes
checking for bamlib... yes
checking for eigenlib... yes
[...]
This should at least make configure work ...

best,
Sven
sklages is offline   Reply With Quote
Old 09-20-2016, 02:52 PM   #4
ohmiyajohn
Junior Member
 
Location: Japan

Join Date: Oct 2010
Posts: 2
Default Additional procedure is necessary.

Furthermore, you need an additional step.
You need to copy version.h to version.hpp.

$ cp /to/path/samtools/include/bam/version.h /to/path/samtools/include/bam/version.hpp

My issue is sorted out by the above procedure.
ohmiyajohn is offline   Reply With Quote
Reply

Tags
bamlib, compile, cufflinks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 07:48 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO