SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
BreakDancer problems totalnew Bioinformatics 5 08-04-2015 01:38 AM
Release notes of SAMtool-0.1.9 lh3 Bioinformatics 0 10-27-2010 07:15 PM
Breakdancer options bawee Bioinformatics 3 03-23-2010 06:01 PM
My notes from Helicos' UBS presentation ECO Helicos / Direct Genomics 17 12-14-2009 06:37 PM
Notes on CHI Next-Gen Conference krobison Events / Conferences 1 10-05-2009 12:25 AM

Reply
 
Thread Tools
Old 04-26-2011, 07:49 AM   #21
hepcat72
Junior Member
 
Location: Princeton, NJ

Join Date: Dec 2009
Posts: 7
Default

I sorted the file using `samtools sort`. I indexed it as well. Still no luck. My output files, aside from the headers, are empty. breakdancer_max complains about missing LB tags in the @RG header line (of which there's only 1). I supplied a file via -f telling bam2cfg.pl to use "NA" as the library for the only readgroup. I didn't indicate the bai file anywhere. Does it find it automatically?
hepcat72 is offline   Reply With Quote
Old 05-25-2011, 12:48 AM   #22
francesconea
Junior Member
 
Location: Milano

Join Date: Apr 2011
Posts: 5
Default

Hi All,

any news about this BreakDancer usage? In addiction, what about BreakDancer Mini? Is that already obsolete? I thought it was good to compare indels retrieval results...
__________________
wherever you go, whatever you do, always bring a bioinformatic with you
francesconea is offline   Reply With Quote
Old 06-21-2011, 01:09 AM   #23
mei404
Junior Member
 
Location: beijing

Join Date: Apr 2011
Posts: 2
Default breakdancer bam2cfg error

when i run perl /usr/local/src/breakdancer-1.1_2011_02_21/perl/bam2cfg.pl ./test_sort.bam , this two error,
Use of uninitialized value in hash element at /usr/local/src/breakdancer-1.1_2011_02_21/perl/bam2cfg.pl line 71, <BAM> line 26.
Use of uninitialized value in hash element at /usr/local/src/breakdancer-1.1_2011_02_21/perl/bam2cfg.pl line 173.
who know how to solve?
I feel anxious! thanks!
mei404 is offline   Reply With Quote
Old 12-09-2011, 06:54 PM   #24
hanifk
Member
 
Location: China

Join Date: Oct 2010
Posts: 18
Default

Quote:
Originally Posted by fabio.marroni View Post
I am trying to run BreakDancer Max on a data set including only one library. Alignment with BWA created an alignment file in which no library name was specified (no @RG header). The bam2cfg.pl included in BreakDancer-0.0.1 (which seems to have incorporated the suggestion from pallo) ran and produced the following config file (config.file):

readgroup:NA platform:illumina map:../Poli/s_1_sequence.bam readlen:75.00 lib:NA num:10001 lower:130.99 upper:275.98 mean:210.78 std:18.14 exe:samtools view

We then ran BrakDancer Max with the following command

perl BreakDancerMax.pl config.file >output.file

and obtained the following (empty) output file
#../Poli/s_1_sequence.bam mean:210.780 std:18.140 uppercutoff:275.980 lowercutoff:130.990 readlen:75.000 library:NA reflen:484660925 seqcov:4.744x phycov:6.667x 1:1784 2:60640 3:59812 4:8280 8:2320 32:48156
#Chr1 Pos1 Orientation1 Chr2 Pos2 Orientation2 Type Size Score num_Reads num_Reads_lib Allele_frequency Version Run_Param

Can someone help with this issue?
I have the same problem with you, did you solve that?
hanifk is offline   Reply With Quote
Old 05-09-2012, 01:23 AM   #25
ritzriya
Member
 
Location: Canada

Join Date: Jun 2010
Posts: 49
Arrow

Quote:
Originally Posted by mei404 View Post
when i run perl /usr/local/src/breakdancer-1.1_2011_02_21/perl/bam2cfg.pl ./test_sort.bam , this two error,
Use of uninitialized value in hash element at /usr/local/src/breakdancer-1.1_2011_02_21/perl/bam2cfg.pl line 71, <BAM> line 26.
Use of uninitialized value in hash element at /usr/local/src/breakdancer-1.1_2011_02_21/perl/bam2cfg.pl line 173.
who know how to solve?
I feel anxious! thanks!
Dear mei404,

I am facing the same problem/error. Did you find any solution to this?

Thanks in advance.
ritzriya is offline   Reply With Quote
Old 05-05-2014, 09:05 AM   #26
jwhite
Member
 
Location: Boston

Join Date: Jun 2012
Posts: 33
Default

Quote:
Originally Posted by ramouz87 View Post
Hi,
Thanks for you reply, I've tried with BWA but still have an empty file when appliying bam2cfg.pl
bwa sampe -a 5000 ~/genomes/Homo_sapiens.GRCh37.56.dna.toplevel.fa ./sai/s_8_1_sequence.fq.bwa.align.sai ./sai/s_8_2_sequence_50b.fq.bwa.align.sai ./fastq/s_8_1_sequence.fq ./fastq/s_8_2_sequence_50b.fq > ./sam/pr_5000_2_50b.bwa.sam

bam2cfg.pl ./bam/pr_5000_2_50b.bwa.bam > ./sv/pr_5000_2_50b.bwa.bam.lst

Beside, I get no error message.

Any intuition regarding the origin of this issue.
Thanks in advance
Best,
Ramzi

Hello,

Do your BAM files include the read group Library (@RG LB:xyz) tag? BreakDancer seems to need the read group in order to work. I had to replace the headers in all my BAM files just to get this program to work. e.g.:

samtools view -H bamfile.bam > header.bam

Edit the header.bam and add the @RG line to include: @RG ID:xyz SM:xyz LB:xyz

Replace the header in your bam file:

samtools reheader header.bam bamfile.bam

Then use bam2cfg.pl. I had to do these one at a time, then run bam2cfg.pl with '>>' to capture output in a single file:

bam2cfg.pl -q 20 -f librarylist -g -h *.bam >> config

(The librarylist is probably not necessary; it could not compensate for BAM files with no LIBrary information. )

HTH,

Joe
jwhite is offline   Reply With Quote
Old 09-09-2015, 05:37 AM   #27
simobioinfo
Member
 
Location: italy

Join Date: Aug 2014
Posts: 38
Default

Hi,
I'm trying to analyze with breakdancer data coming from ion torrent, which were aligned through tmap.
I ran bam2cfg.pl but I obtained an empty file.
This is the message:
[Wed Sep 9 15:26:19 2015 ./bam2cfg.pl] Closing BAM file
[Wed Sep 9 15:26:19 2015 ./bam2cfg.pl] Send TERM signal for 4992
[Wed Sep 9 15:26:21 2015 ./bam2cfg.pl] samtools pid process 4992 is still there...
[Wed Sep 9 15:26:21 2015 ./bam2cfg.pl] invoking kill -9 on 4992 ...
[Wed Sep 9 15:26:21 2015 ./bam2cfg.pl] Closing samtools process : 4992

At the beginning I have error regarding RG group and so through picard AddOrReplaceReadGroup I modified it.
Now I don't know how to solve this issue.
What is the problem?
Could anybody help me?
simobioinfo is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 10:47 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO