SEQanswers

Go Back   SEQanswers > Applications Forums > RNA Sequencing



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble running Tophat & Cufflinks on Galaxy with non-UCSC-supported genome NSher Bioinformatics 2 12-29-2011 07:05 PM
Trouble getting TopHat to work -- empty junctions.bed thurisaz RNA Sequencing 6 12-01-2011 11:13 AM
tophat hg19 index madsaan Bioinformatics 1 06-10-2011 09:56 PM
tophat-bowtie building index repinementer Bioinformatics 1 07-17-2010 10:53 PM
Tophat and Bowtie Index Siva Bioinformatics 1 03-09-2010 01:44 PM

Reply
 
Thread Tools
Old 11-28-2012, 04:35 PM   #1
Xinlitik
Junior Member
 
Location: California

Join Date: Nov 2012
Posts: 7
Default Tophat trouble reconstituting index

Hi all,

I'm new to the field so please forgive my ignorance. I setup Tophat, Bowtie, and SamTools and attempted to run tophat on some samples. This is the message it produced:

[2012-11-28 19:56:55] Beginning TopHat run (v2.0.6)
-----------------------------------------------
[2012-11-28 19:56:55] Checking for Bowtie
Bowtie 2 not found, checking for older version..
Bowtie version: 0.12.8.0
[2012-11-28 19:56:55] Checking for Samtools
Samtools version: 0.1.18.0
[2012-11-28 19:56:55] Checking for Bowtie index files
[2012-11-28 19:56:55] Checking for reference FASTA file
[2012-11-28 19:56:55] Generating SAM header for /u/home/mcdb/x/bowtie-0.12.8/indexes/genome
format: fastq
quality scale: phred64 (reads generated with GA pipeline version >= 1.3)
[2012-11-28 19:58:09] Reading known junctions from GTF file
[2012-11-28 19:58:21] Preparing reads
left reads: min. length=50, max. length=50, 75848803 kept reads (6201 discarded)
[2012-11-28 20:17:00] Creating transcriptome data files..
[FAILED]
Error: gtf_to_fasta returned an error.
open: No such file or directory
[main_samview] fail to open "R1/accepted_hits.bam" for reading.
cp: cannot stat `R1/accepted_hits.bam': No such file or directory

This is a different error than I first posted, sorry. I can't figure out why I am getting the gtf_to_fasta error. I downloaded Ensembl's NCBIM37 for mouse here: http://cufflinks.cbcb.umd.edu/igenomes.html. Then I used the mus_musculus gtf included in it, as well as the genome.ebwt files included in the BowtieIndex folder of the unpacked file. I read in another post that this error could be from the fasta and gtf files having different names, so I renamed them both genome but got the same error.


Any help is appreciated. Thanks!

Last edited by Xinlitik; 11-28-2012 at 08:03 PM.
Xinlitik is offline   Reply With Quote
Old 11-28-2012, 09:02 PM   #2
Wallysb01
Senior Member
 
Location: San Francisco, CA

Join Date: Feb 2011
Posts: 286
Default

Can your post your command? It looks like it having trouble just finding the file. You might double check that the paths are correct?
Wallysb01 is offline   Reply With Quote
Old 11-29-2012, 05:27 AM   #3
Xinlitik
Junior Member
 
Location: California

Join Date: Nov 2012
Posts: 7
Default

Quote:
Originally Posted by Wallysb01 View Post
Can your post your command? It looks like it having trouble just finding the file. You might double check that the paths are correct?
Thanks for the reply. I "fixed" the problem by pilfering a labmate's gtf and .ewbt files. The ebwt files had identical sizes so that was just to be safe, so the different GTF must have been the problem. The thing is, I don't know why, hah. Any reason why the GTF included in the link in my first post would not work? The one I used successfully was also ensembl (mm9.ensembl.gtf) so I'm not sure why it failed. Does filename matter? Should I have tried e.g. genome.ensembl.gtf to go with genome.ewbt1234?

Here is the command:

tophat --solexa1.3-quals --no-coverage-search -g 1 -G /u/home/mcdb/dashraf/GTF/mm9.ensembl.gtf -p 8 -o ./$k /u/home/mcdb/x/bowtie-0.12.8/indexes/temp/mm9 $k.fastq

(the /temp/ is because I added the labmate ewbts in a new folder)
Xinlitik is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 06:04 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO