SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error while running Tophat 2.0.11 SubodhTambat RNA Sequencing 0 07-28-2014 01:02 AM
TopHat error - error running prep_reads ajaffe RNA Sequencing 0 11-29-2012 07:09 AM
tophat Error running running 'prep_reads' victoryhe Bioinformatics 2 10-17-2011 04:53 AM
Tophat running error 1? day_sleeperz RNA Sequencing 2 10-04-2011 07:19 AM
Tophat Running Error Wei-HD Bioinformatics 12 02-11-2010 02:42 PM

Reply
 
Thread Tools
Old 08-23-2014, 01:47 PM   #1
Alessandro_S
Junior Member
 
Location: San Francisco

Join Date: Jun 2014
Posts: 2
Default Error running test in Tophat

Hi everybody, I'm new to the RNA-seq data analysis world and I really need your help.
Just one premise: I have poor experience in coding/programming.

I'm using a Mac Pro (2 x 2.8 GHz Quad-core, 18GB RAM). I've installed SAM tools, Boost 1_55_0, Bowtie 2.2.3 and Tophat-2.0.12 (pre compiled for Mac OSX 64bit). I followed the installation instructions that I found in the corresponding manuals and I tested successfully Bowtie2.

But when I tested Tophat (using the test_data file as suggested in the "getting started" manual), I came across this error:

Quote:
[2014-08-23 14:03:53] Beginning TopHat run (v2.0.12)
-----------------------------------------------
[2014-08-23 14:03:53] Checking for Bowtie
Bowtie version: 2.2.2.0
[2014-08-23 14:03:53] Checking for Samtools
Samtools version: 0.1.16.0
[2014-08-23 14:03:53] Checking for Bowtie index files (genome)..
[2014-08-23 14:03:53] Checking for reference FASTA file
[2014-08-23 14:03:53] Generating SAM header for test_ref
[2014-08-23 14:03:53] Preparing reads
left reads: min. length=75, max. length=75, 100 kept reads (0 discarded)
right reads: min. length=75, max. length=75, 100 kept reads (0 discarded)
[2014-08-23 14:03:53] Mapping left_kept_reads to genome test_ref with Bowtie2
[2014-08-23 14:03:53] Mapping left_kept_reads_seg1 to genome test_ref with Bowtie2 (1/3)
[2014-08-23 14:03:53] Mapping left_kept_reads_seg2 to genome test_ref with Bowtie2 (2/3)
[2014-08-23 14:03:53] Mapping left_kept_reads_seg3 to genome test_ref with Bowtie2 (3/3)
[2014-08-23 14:03:53] Mapping right_kept_reads to genome test_ref with Bowtie2
[2014-08-23 14:03:54] Mapping right_kept_reads_seg1 to genome test_ref with Bowtie2 (1/3)
[2014-08-23 14:03:54] Mapping right_kept_reads_seg2 to genome test_ref with Bowtie2 (2/3)
[2014-08-23 14:03:54] Mapping right_kept_reads_seg3 to genome test_ref with Bowtie2 (3/3)
[2014-08-23 14:03:54] Searching for junctions via segment mapping
[2014-08-23 14:03:54] Retrieving sequences for splices
[2014-08-23 14:03:54] Indexing splices
[2014-08-23 14:03:54] Mapping left_kept_reads_seg1 to genome segment_juncs with Bowtie2 (1/3)
[2014-08-23 14:03:54] Mapping left_kept_reads_seg2 to genome segment_juncs with Bowtie2 (2/3)
[2014-08-23 14:03:55] Mapping left_kept_reads_seg3 to genome segment_juncs with Bowtie2 (3/3)
[2014-08-23 14:03:55] Joining segment hits
[FAILED]
Error running 'long_spanning_reads':
And this is the long_spanning_reads.segs.log file:

Quote:
long_spanning_reads v2.0.12 (4277)
--------------------------------------------
Opening /dev/null for reading
[samopen] SAM header is present: 1 sequences.
Loading reference sequences...
reference sequences loaded.
Loading junctions...done
Loading deletions...done
Loading insertions...done
dyld: lazy symbol binding failed: Symbol not found: __ZNSt15_List_node_base7_M_hookEPS_
Referenced from: /***/***/***/***/long_spanning_reads
Expected in: /usr/lib/libstdc++.6.dylib

dyld: Symbol not found: __ZNSt15_List_node_base7_M_hookEPS_
Referenced from: /***/***/***/***/long_spanning_reads
Expected in: /usr/lib/libstdc++.6.dylib
I've read several threads but I couldn't find an answer or a solution.

Could you please help me? I have no idea of what is going on.

Thank you,

Alessandro.
Alessandro_S is offline   Reply With Quote
Old 08-24-2014, 03:53 AM   #2
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 7,077
Default

There *may* be a problem with published TopHat Mac binaries for some time, in terms of how they are linked to libraries. See this thread for related information: http://seqanswers.com/forums/showthread.php?t=45349

Do you have the latest Xcode tools installed?
GenoMax is offline   Reply With Quote
Old 08-25-2014, 08:13 AM   #3
Alessandro_S
Junior Member
 
Location: San Francisco

Join Date: Jun 2014
Posts: 2
Default

Hi GenoMax,

Thank you so much for your help.

Switching to TopHat v.2.0.9 and Bowtie 2.1.0.0 solved the problem:

Quote:
[2014-08-25 09:08:17] Beginning TopHat run (v2.0.9)
-----------------------------------------------
[2014-08-25 09:08:17] Checking for Bowtie
Bowtie version: 2.1.0.0
[2014-08-25 09:08:17] Checking for Samtools
Samtools version: 0.1.19.0
[2014-08-25 09:08:17] Checking for Bowtie index files (genome)..
Found both Bowtie1 and Bowtie2 indexes.
[2014-08-25 09:08:17] Checking for reference FASTA file
[2014-08-25 09:08:17] Generating SAM header for test_ref
format: fastq
quality scale: phred33 (default)
[2014-08-25 09:08:18] Preparing reads
left reads: min. length=75, max. length=75, 100 kept reads (0 discarded)
right reads: min. length=75, max. length=75, 100 kept reads (0 discarded)
[2014-08-25 09:08:18] Mapping left_kept_reads to genome test_ref with Bowtie2
[2014-08-25 09:08:18] Mapping left_kept_reads_seg1 to genome test_ref with Bowtie2 (1/3)
[2014-08-25 09:08:18] Mapping left_kept_reads_seg2 to genome test_ref with Bowtie2 (2/3)
[2014-08-25 09:08:18] Mapping left_kept_reads_seg3 to genome test_ref with Bowtie2 (3/3)
[2014-08-25 09:08:19] Mapping right_kept_reads to genome test_ref with Bowtie2
[2014-08-25 09:08:19] Mapping right_kept_reads_seg1 to genome test_ref with Bowtie2 (1/3)
[2014-08-25 09:08:19] Mapping right_kept_reads_seg2 to genome test_ref with Bowtie2 (2/3)
[2014-08-25 09:08:19] Mapping right_kept_reads_seg3 to genome test_ref with Bowtie2 (3/3)
[2014-08-25 09:08:19] Searching for junctions via segment mapping
[2014-08-25 09:08:19] Retrieving sequences for splices
[2014-08-25 09:08:19] Indexing splices
[2014-08-25 09:08:19] Mapping left_kept_reads_seg1 to genome segment_juncs with Bowtie2 (1/3)
[2014-08-25 09:08:19] Mapping left_kept_reads_seg2 to genome segment_juncs with Bowtie2 (2/3)
[2014-08-25 09:08:19] Mapping left_kept_reads_seg3 to genome segment_juncs with Bowtie2 (3/3)
[2014-08-25 09:08:19] Joining segment hits
[2014-08-25 09:08:19] Mapping right_kept_reads_seg1 to genome segment_juncs with Bowtie2 (1/3)
[2014-08-25 09:08:19] Mapping right_kept_reads_seg2 to genome segment_juncs with Bowtie2 (2/3)
[2014-08-25 09:08:19] Mapping right_kept_reads_seg3 to genome segment_juncs with Bowtie2 (3/3)
[2014-08-25 09:08:19] Joining segment hits
[2014-08-25 09:08:19] Reporting output tracks
-----------------------------------------------
[2014-08-25 09:08:19] A summary of the alignment counts can be found in ./tophat_out/align_summary.txt
[2014-08-25 09:08:19] Run complete: 00:00:02 elapsed
I'm still wondering if it's a problem related to my machine (my Xcode was updated) or with Tophat 2.0.12 pre-compiled release for MacOSX.
Alessandro_S is offline   Reply With Quote
Old 08-25-2014, 08:16 AM   #4
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 7,077
Default

AFAIK the problem is with the latest pre-compiled OS X binaries for TopHat. Unfortunately no one from Tuxedo suite team seem to actively participate on this forum.

Last edited by GenoMax; 08-25-2014 at 08:18 AM.
GenoMax is offline   Reply With Quote
Old 08-25-2014, 11:03 AM   #5
dpryan
Devon Ryan
 
Location: Freiburg, Germany

Join Date: Jul 2011
Posts: 3,480
Default

They aren't even active in their own google group or in replying to bug reports. My rule of thumb is to give an issue 3-4 months before expecting a reply from them.
dpryan is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 09:17 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO