Go Back   SEQanswers > Applications Forums > RNA Sequencing

Similar Threads
Thread Thread Starter Forum Replies Last Post
Picard Issue ercfrtz Bioinformatics 1 06-05-2012 09:00 AM
Issue with LiftOver ashkot Bioinformatics 1 05-17-2012 10:25 AM
CisGenome Issue Nicholas_ Bioinformatics 0 10-10-2011 01:24 AM
bioscope mapping issue cjose Bioinformatics 2 08-05-2011 08:00 AM
Coverage issue hersh Bioinformatics 0 03-18-2009 10:17 PM

Thread Tools
Old 08-22-2012, 05:03 AM   #1
Location: USA

Join Date: Jun 2012
Posts: 23
Default SeqTrimMap mapping issue

I have Illumina smallRNA-RNAseq reads that have already had their adapters removed and have been filtered for tRNA/rRNA.

I'm trying to use SeqTrimMap to align these reads to my reference genome with the following command:

$SeqTrimMap -b -S -i -v 1 -o ~/seqtrimmap_B_output_496_1 -s -u 18 -t 28 ~/496_1_filtered_18_28nt.fa  ~/zma_b.fa
The program runs well and gives me output in SAM format as requested, but the program will only map reads at lengths 20-24 nt. Does anyone have a suggestion that might allow me to map reads at additional lengths?
rndouglas is offline   Reply With Quote
Old 08-27-2012, 01:26 AM   #2
Location: Dundee, Scotland

Join Date: Mar 2009
Posts: 29

Hi rndouglas,

it sounds like SeqTrimMap is suppressing anything that isn't small RNA.

Here is what I would do:

1. Convert the SAM file that SeqTrimMap produced to BAM format.

2. Extract the unmapped reads from this. You can do that with samtools like so:

samtools view -f4 sample.bam > sample.unmapped.sam

3. Extract the unmapped reads from the sam file you just created and convert these into FASTQ format. I don't know if there is a tool for this so you may have to script it yourself.

4. Map those reads with another mapping tool that will map regardless of length, e.g. Bowtie, BWA etc. Convert your output into BAM if it isn't that already.

5. Merge the two BAM files with samtools merge (see using the -r flag. This will produce a single BAM file which contains both the shorter and the longer reads, but they will be distinguishable because samtools merge adds a read group tag to each read. This will give you a trail of where each read came from.

6. You can visualise this quite nicely in Tablet ( It includes a "colour by read group" colouring scheme which colours each read according to which read group it belongs to. If you select a contig and then click on the 4th tab in the left hand panel you will see a list of the read groups. The check boxes allow you to switch colour for each read group on and off individually so you can grey out one lot and make the other one stand out.

Hope this helps.

mbayer is offline   Reply With Quote
Old 08-27-2012, 03:56 AM   #3
Location: USA

Join Date: Jun 2012
Posts: 23

Thanks for the suggestion!

I also contacted the program author directly and was told that this sort of thing has popped up with Illumina data before.

With Illumina input the program uses the length of the first line in the input FASTA as the maximum length. In my case, the first line always happened to be a 24nt sRNA.

When I moved a 28nt sRNA to the top of the list the program ran as desired.
rndouglas is offline   Reply With Quote
Old 10-26-2012, 04:44 AM   #4
Junior Member
Location: Manchetser, UK

Join Date: Nov 2009
Posts: 5

I'm glad you got around it. Let me know if any other issue appears.
toni_marco is offline   Reply With Quote

mapping, rnaseq, seqtrimmap, srna

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -8. The time now is 11:02 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO