SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
ShortRead package bioinfosm Bioinformatics 9 06-01-2014 09:25 AM
Using Trinity package aevgup RNA Sequencing 8 02-04-2012 02:15 AM
Staden package question: is srf2fastq returning an error, or is this normal? mhayes Bioinformatics 4 12-12-2011 10:54 AM
DESeq package(1.5.24) elisadouzi Bioinformatics 1 10-01-2011 02:02 AM
Simulation package in R Jasmine Bioinformatics 0 07-05-2011 08:27 AM

Reply
 
Thread Tools
Old 12-08-2010, 06:09 AM   #1
masylichu
Member
 
Location: Beijing, China

Join Date: Oct 2010
Posts: 30
Default a question about the use of R package-GenomicFeatures

Hi,all
i want to use the R biocondunctor package-GenomicFeatures.and i follow the manual to install this package.

To install this package, start R and enter:

source("http://bioconductor.org/biocLite.R")
biocLite("GenomicFeatures")

it sounds no problem.

however, when i type R and enter the R command,
>library(GenomicFeatures)
>txdb<- makeTranscriptDbFromUCSC(genome='hg19',tablename='ensGene'),

Error: could not find function "makeTranscriptDbFromUCSC"

why?

could someone help me to solve this?
masylichu is offline   Reply With Quote
Old 12-08-2010, 06:44 AM   #2
Zigster
(Jeremy Leipzig)
 
Location: Philadelphia, PA

Join Date: May 2009
Posts: 116
Default

that's weird
i'll assume the trailing comma and space before ' ensGene' are just typos

what does it say when you type:
> ls("package:GenomicFeatures")
__________________
--
Jeremy Leipzig
Bioinformatics Programmer
--
My blog
Twitter
Zigster is offline   Reply With Quote
Old 12-08-2010, 05:15 PM   #3
masylichu
Member
 
Location: Beijing, China

Join Date: Oct 2010
Posts: 30
Default

> ls("package:GenomicFeatures")
[1] "exons" "extractTranscriptsFromGenome"
[3] "introns" "transcripts"

this is the output.
masylichu is offline   Reply With Quote
Old 12-08-2010, 05:20 PM   #4
masylichu
Member
 
Location: Beijing, China

Join Date: Oct 2010
Posts: 30
Default

also, the problem happen after i deleted the space before ' ensGene'.


Quote:
Originally Posted by Zigster View Post
that's weird
i'll assume the trailing comma and space before ' ensGene' are just typos

what does it say when you type:
> ls("package:GenomicFeatures")
masylichu is offline   Reply With Quote
Old 12-08-2010, 05:24 PM   #5
Zigster
(Jeremy Leipzig)
 
Location: Philadelphia, PA

Join Date: May 2009
Posts: 116
Default

that comes from an old version of Bioconductor

Install R 2.12.0 then reinstall Bioconductor
__________________
--
Jeremy Leipzig
Bioinformatics Programmer
--
My blog
Twitter
Zigster is offline   Reply With Quote
Old 12-08-2010, 05:26 PM   #6
masylichu
Member
 
Location: Beijing, China

Join Date: Oct 2010
Posts: 30
Default

all right. i will have a try.


Quote:
Originally Posted by Zigster View Post
that comes from an old version of Bioconductor

Install R 2.12.0 then reinstall Bioconductor
masylichu is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 03:32 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO