SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bowtie Exec format error. Wrong Architecture. tboothby Bioinformatics 2 12-01-2011 11:25 AM
bowtie - invalid CIGAR string - wrong sam format genome Bioinformatics 2 02-16-2011 01:36 PM
Bowtie parameters khb Bioinformatics 11 12-16-2010 09:08 PM
something wrong with tophat-1.0.14 version, don't use it frankyue50 Bioinformatics 4 10-04-2010 08:33 AM
Recommended Bowtie Parameters agc SOLiD 0 05-10-2010 03:44 AM

Reply
 
Thread Tools
Old 08-23-2011, 01:18 AM   #1
chenyao
Member
 
Location: Beijing

Join Date: Jul 2011
Posts: 74
Default Wrong of Tophat's bowtie parameters, a bug

Dear all,

I use tophat --bowtie-n 4 to set bowtie mismatch, however, I found the error,

[Tue Aug 23 17:09:09 2011] Beginning TopHat run (v1.3.1)
-----------------------------------------------
[Tue Aug 23 17:09:09 2011] Preparing output location /tophat
[Tue Aug 23 17:09:09 2011] Checking for Bowtie index files
Error: Could not find Bowtie index files 4.*

It seems tophat recognize the bowtie command as a index file, however, I have pointed the index file in the command line, anyone idea?
chenyao is offline   Reply With Quote
Old 08-23-2011, 04:09 AM   #2
sdvie
Member
 
Location: Spain

Join Date: Jul 2010
Posts: 68
Default

could you paste your whole tophat command here please?
sdvie is offline   Reply With Quote
Old 08-23-2011, 04:31 AM   #3
fkrueger
Senior Member
 
Location: Cambridge, UK

Join Date: Sep 2009
Posts: 625
Default

Quote:
Originally Posted by chenyao View Post
Dear all,

I use tophat --bowtie-n 4 to set bowtie mismatch, however, I found the error,

[Tue Aug 23 17:09:09 2011] Beginning TopHat run (v1.3.1)
-----------------------------------------------
[Tue Aug 23 17:09:09 2011] Preparing output location /tophat
[Tue Aug 23 17:09:09 2011] Checking for Bowtie index files
Error: Could not find Bowtie index files 4.*

It seems tophat recognize the bowtie command as a index file, however, I have pointed the index file in the command line, anyone idea?
'--bowtie-n' is an option which does not take integer arguments. I guess you can specify the number of mismatches separately such as with '--initial-read-mismatches': Reads are initially mapped, allowing up to this many mismatches in each read alignment. The default is 2.

Also, -n can only be 0 to 3, and the default is 2, so -n 4 would fail as well.
fkrueger is offline   Reply With Quote
Old 08-23-2011, 05:06 AM   #4
chenyao
Member
 
Location: Beijing

Join Date: Jul 2011
Posts: 74
Default

Quote:
Originally Posted by fkrueger View Post
'--bowtie-n' is an option which does not take integer arguments. I guess you can specify the number of mismatches separately such as with '--initial-read-mismatches': Reads are initially mapped, allowing up to this many mismatches in each read alignment. The default is 2.

Also, -n can only be 0 to 3, and the default is 2, so -n 4 would fail as well.
Thank you, If it's up to 3, the I understand the error. Another question is for pair-end reads, such as 50bp*25bp, the mismatch value is the same for both reads. But since the length of reads are different, they shouldn't have the same mismatch probability. Is there anyway to seperately set the mismatch value?
chenyao is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 02:36 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO