SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
samtools mpileup: -B or not to -B? yenhuahuang1 Bioinformatics 4 03-19-2013 03:21 AM
samtools mpileup error meher Bioinformatics 3 10-09-2012 12:47 AM
Problem Encountered When Using SOAPdenovo: Floating Point / Segmentation Error andyding Bioinformatics 0 11-21-2011 09:35 AM
samtools tview produces "Floating point exception" on big file? pmaugeri Bioinformatics 2 10-28-2011 08:06 AM
samtools mpileup error nicklin Bioinformatics 0 03-17-2011 08:20 PM

Reply
 
Thread Tools
Old 07-08-2011, 05:57 AM   #1
Hkins552
Member
 
Location: Baltimore MD

Join Date: Jun 2011
Posts: 18
Question samtools mpileup floating point error

Hi All,
I am having trouble with mpileup today on samtools.

$ samtools mpileup -uf human_g1k_v37.fasta input.recal.bam > input.variants.raw

[mpileup] 1 samples in 1 input files
<mpileup> Set max per-file depth to 8000
Floating point exception


Any ideas on this floating point exception error?
Hkins552 is offline   Reply With Quote
Old 07-15-2011, 10:17 AM   #2
DrDolittle
Junior Member
 
Location: New York

Join Date: Oct 2010
Posts: 3
Default

Hi,

I experienced the same error recently on our linux server with samtools 0.1.16 and 0.1.17 (including the lates build). The bam files are ok (checked with Picard). Interestingly, this command (again different samtools versions) runs smoothly on an iMac machine? Can someone give a hint to a solution? Any help appreciated!

The bam files were created as follows (on the linux/red hat server):
bwa aln -I -n 1 -t 10 g1k.fasta in.fastq > out.sai
bwa samse g1k.fasta out.sai in.fastq -f myfile.sam
samtools view -bhS myfile.sam -o myfile.bam
samtools sort myfile.bam myfile_sorted
samtools index myfile_sorted.bam

bwa-0.5.9-r16
samtools-0.1.17 (0.1.17)
DrDolittle is offline   Reply With Quote
Old 08-31-2011, 07:37 PM   #3
Xueya Zhou
Junior Member
 
Location: Beijing, China

Join Date: Nov 2010
Posts: 1
Default

I encountered the same problem with samtools version 1.13 to 1.17.

I found it can be solved by replacing the numeric chromosome names 1..22 in GRCh37 with chr1..chr22 within the bam file header.
Xueya Zhou is offline   Reply With Quote
Old 05-17-2012, 11:28 PM   #4
bw.
Member
 
Location: San Francisco, CA

Join Date: Mar 2012
Posts: 21
Default Also getting this error with samtools 0.1.17 and 0.1.18

Hi,
I'm running samtools on a 64bit linux server after compiling the tool on this server using make (no issues during the compilation).

I'm getting the float point error and it happens even if I don't provide any input .bam files:

samtools mpileup -f Libraries/hg19/hg19.fa
[mpileup] 0 samples in 0 input files
Floating point exception

It does also happen when I provide .bam files - making the tool unusable.

The hg19.fa has chromosome names "chr1", "chr2", etc. so the chromosome name work-around mentioned above didn't work in my case.

However, samtools vs. 0.1.12 does work both with and without input .bam files (it was compiled on this same server).

Any help or work arounds would be much appreciated.

-Ben

Ps. I also tried regenerating the .fai file but it didn't help, and also checked for dependency issues but at first glance things look alright:

ldd ./samtools
libncurses.so.5 => /usr/lib64/libncurses.so.5 (0x00000039a8600000)
libm.so.6 => /lib64/libm.so.6 (0x0000003995800000)
libz.so.1 => /usr/lib64/libz.so.1 (0x0000003996400000)
libc.so.6 => /lib64/libc.so.6 (0x0000003995400000)
libdl.so.2 => /lib64/libdl.so.2 (0x0000003995c00000)
/lib64/ld-linux-x86-64.so.2 (0x0000003995000000)
bw. is offline   Reply With Quote
Old 06-29-2012, 07:50 PM   #5
wencanh
Junior Member
 
Location: China

Join Date: Mar 2012
Posts: 5
Default Wonderful

I encountered the same problem and I solved it with the help of the thread posted by Xueya Zhou. Thank you very much


Quote:
Originally Posted by Xueya Zhou View Post
I encountered the same problem with samtools version 1.13 to 1.17.

I found it can be solved by replacing the numeric chromosome names 1..22 in GRCh37 with chr1..chr22 within the bam file header.
wencanh is offline   Reply With Quote
Old 08-14-2012, 12:32 AM   #6
yanlinlin82
Junior Member
 
Location: Beijing

Join Date: Nov 2010
Posts: 1
Default

I met the same error. I found it may be caused by the incorrect index file (.fai). Use 'samtools index' to re-build index for the reference file solved the problem in my case.
yanlinlin82 is offline   Reply With Quote
Old 10-05-2012, 02:27 AM   #7
kingsalex
member
 
Location: london, uk

Join Date: Nov 2010
Posts: 4
Default mpileup floating point error gatk fai file problem

Yes it seems to be fai problem for me too. ie when i use new fai file it works ok . I think it has something to do with the format of the Fai file GATK builds automatically if you let it.
kingsalex is offline   Reply With Quote
Old 11-15-2012, 04:55 AM   #8
genomicist
Member
 
Location: Sweden

Join Date: Jan 2011
Posts: 12
Default

Quote:
Originally Posted by yanlinlin82 View Post
I met the same error. I found it may be caused by the incorrect index file (.fai). Use 'samtools index' to re-build index for the reference file solved the problem in my case.
Thanks a lot for this solution. Only I think you mean "samtools faidx" and not "samtools index".
genomicist is offline   Reply With Quote
Old 01-08-2013, 05:47 PM   #9
chung2000
Junior Member
 
Location: Massachusetts

Join Date: Jan 2013
Posts: 1
Default samtools mpileup floating point error

Quote:
Originally Posted by genomicist View Post
Thanks a lot for this solution. Only I think you mean "samtools faidx" and not "samtools index".
Thank you, that saved me a lot of consternation when it came time for me to re-index my BAM files.
chung2000 is offline   Reply With Quote
Old 01-09-2013, 02:46 AM   #10
drashu_11
Junior Member
 
Location: Foulum, Tejle, Denmark

Join Date: Jan 2013
Posts: 2
Default

Hi
I am having trouble with vcfutils.pl command

I used the follwing command

samtools view mpileup -uf ref.fa aln.bam | bcftools view -bvcg - > raw.bcf

and I have the raw.bcf

But when I used the following command to build concensus

bcftools view raw.bcf | vcfutils.pl vcf2fq > cons.fq

Then I have the fowwing error message

vcfutils.pl command not found

I need help
__________________
Ashutosh Das
PhD fellow
Molecular Genetics and System Biology
Department of Molecular Biology and Genetics
Aarhus University, Blichers Alle 20, Postbox 50
8830, Tjele, Denmark
drashu_11 is offline   Reply With Quote
Old 01-09-2013, 10:29 PM   #11
drashu_11
Junior Member
 
Location: Foulum, Tejle, Denmark

Join Date: Jan 2013
Posts: 2
Default

Quote:
Originally Posted by drashu_11 View Post
Hi
I am having trouble with vcfutils.pl command

I used the follwing command

samtools view mpileup -uf ref.fa aln.bam | bcftools view -bvcg - > raw.bcf

and I have the raw.bcf

But when I used the following command to build concensus

bcftools view raw.bcf | vcfutils.pl vcf2fq > cons.fq

Then I have the fowwing error message

vcfutils.pl command not found

I need help

Ignore the quoted message I could manage that problem
__________________
Ashutosh Das
PhD fellow
Molecular Genetics and System Biology
Department of Molecular Biology and Genetics
Aarhus University, Blichers Alle 20, Postbox 50
8830, Tjele, Denmark
drashu_11 is offline   Reply With Quote
Old 08-02-2013, 06:58 AM   #12
dGho
Member
 
Location: Rochester, NY

Join Date: Jan 2013
Posts: 43
Default

Quote:
Originally Posted by Xueya Zhou View Post
I encountered the same problem with samtools version 1.13 to 1.17.

I found it can be solved by replacing the numeric chromosome names 1..22 in GRCh37 with chr1..chr22 within the bam file header.
This may be a silly question, but I don't get how you would change the chromosome names in bam files...they are binary, did you mean you changed the headers in the sam files?
dGho is offline   Reply With Quote
Old 03-02-2014, 08:13 AM   #13
patrickc01
Junior Member
 
Location: United States

Join Date: Mar 2014
Posts: 1
Default

Quote:
Originally Posted by drashu_11 View Post
Ignore the quoted message I could manage that problem
Hi,
I am new to bioinformatics and have run into the same problem. Could you tell me how you solved it?

Thanks!
patrickc01 is offline   Reply With Quote
Reply

Tags
error, floating, mpileup, point, samtools

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 08:42 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO