SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
OrthoMCL duplicate entry error flipwell Bioinformatics 6 09-24-2013 06:48 AM
Orthomcl warning message joscarhuguet Bioinformatics 0 04-20-2011 08:13 AM
Orthomcl warning message joscarhuguet General 0 04-13-2011 12:47 PM
Warning message in orthomcl v1.4 joscarhuguet Bioinformatics 0 04-13-2011 09:46 AM
Orthomcl Installation Canadian_philosophy Bioinformatics 0 07-29-2010 07:36 AM

Reply
 
Thread Tools
Old 06-24-2011, 12:12 PM   #1
zxl124
Junior Member
 
Location: university park, pa

Join Date: Aug 2009
Posts: 4
Default orthomcl error

I ran into a problem running orthomcl for the first time. I was stuck at orthomclPairs step. Error message reads below.

DBD::mysql::st execute failed: Lost connection to MySQL server during query at ../bin/orthomclPairs line 693, <F> line 14.
Lost connection to MySQL server during query at ../bin/orthomclPairs line 693, <F> line 14.

The log file reads below:

Fri Jun 24 15:34:04 2011 configuration: dbVendor=mysql
Fri Jun 24 15:34:04 2011 configuration: dbConnectString=dbi:mysqlrthomcl:local
host:3307
Fri Jun 24 15:34:04 2011 configuration: dbLogin=orthomcl
Fri Jun 24 15:34:04 2011 configuration: dbPassword=********
Fri Jun 24 15:34:04 2011 configuration: similarSequencesTable=SimilarSequences
Fri Jun 24 15:34:04 2011 configuration: orthologTable=Ortholog
Fri Jun 24 15:34:04 2011 configuration: inParalogTable=InParalog
Fri Jun 24 15:34:04 2011 configuration: coOrthologTable=CoOrtholog
Fri Jun 24 15:34:04 2011 configuration: interTaxonMatchView=InterTaxonMatch
Fri Jun 24 15:34:04 2011 configuration: percentMatchCutoff=50
Fri Jun 24 15:34:04 2011 configuration: evalueExponentCutoff=-5
Fri Jun 24 15:34:04 2011 configuration: oracleIndexTblSpc=NONE
Fri Jun 24 15:34:04 2011 Constructing common temp tables
Fri Jun 24 15:34:04 2011 Find min evalue exp (OrthoMCL-DB V2 took ??? for thi
s step)
Fri Jun 24 15:34:05 2011 done
Fri Jun 24 15:34:05 2011 updating SimilarSequences, setting 0 evalue_exp to un
derflow value (-180 - 1) (Benchmark dataset took 25 min for this step)
Fri Jun 24 15:34:09 2011 step 'updateMinimumEvalueExponent' done (1 mins)

Fri Jun 24 15:34:09 2011 create BestQueryTaxonScore (Benchmark dataset took 1
.5 hours for this step)

It sounds like a problem with my mysql server, isn't it? But the previous steps were OK, and I am able to connect to it, so I am confused. Could anyone with experience with this program please help me fix this? Thank you very much.
zxl124 is offline   Reply With Quote
Old 01-14-2012, 02:24 PM   #2
kmkocot
Member
 
Location: Alabama

Join Date: Jun 2009
Posts: 48
Default

I am having trouble at this step as well. The error I get is different, though.

orthomclPairs orthomcl.config orthomclPairs.log cleanup=yes
DBD::mysql::st execute failed: Table 'orthomcl.OrthologTemp' doesn't exist at /usr/local/orthomcl/bin/orthomclPairs line 668, <F> line 12.
Table 'orthomcl.OrthologTemp' doesn't exist at /usr/local/orthomcl/bin/orthomclPairs line 668, <F> line 12.
kmkocot is offline   Reply With Quote
Old 05-22-2012, 07:05 AM   #3
rahularjun86
Member
 
Location: Frankfurt(M), Germany

Join Date: Jan 2011
Posts: 58
Default

Hi All,
I am also getting an error in the 4th Step "orthomclInstallSchema"
HTML Code:
[rsharma@primary my_orthomcl_dir]$ orthomclInstallSchema orthomcl.config.template 
DBI connect('orthomcl:3307','orthomcl',...) failed: Can't connect to MySQL server on '3307' (22) at /home/rsharma/Software/orthomclSoftware-v2.0.3/bin/../lib/perl/OrthoMCLEngine/Main/Base.pm line 56.
Can't connect to MySQL server on '3307' (22) at /home/rsharma/Software/orthomclSoftware-v2.0.3/bin/../lib/perl/OrthoMCLEngine/Main/Base.pm line 56, <F> line 14.
I did the mysql installations on my home directory without su privileges. I would really appreciate if someone could help me out.
Regards,
Rahul
__________________
Rahul Sharma,
Ph.D
Frankfurt am Main, Germany
rahularjun86 is offline   Reply With Quote
Old 02-12-2013, 06:32 AM   #4
set
Junior Member
 
Location: Belgium

Join Date: Feb 2013
Posts: 1
Default

Quote:
Originally Posted by kmkocot View Post
I am having trouble at this step as well. The error I get is different, though.

orthomclPairs orthomcl.config orthomclPairs.log cleanup=yes
DBD::mysql::st execute failed: Table 'orthomcl.OrthologTemp' doesn't exist at /usr/local/orthomcl/bin/orthomclPairs line 668, <F> line 12.
Table 'orthomcl.OrthologTemp' doesn't exist at /usr/local/orthomcl/bin/orthomclPairs line 668, <F> line 12.
Hi,

have you solved this? I get the same error but then already at the LoadBlast step.

Thank you
set is offline   Reply With Quote
Old 02-25-2013, 03:24 PM   #5
kmkocot
Member
 
Location: Alabama

Join Date: Jun 2009
Posts: 48
Default

Unfortunately I didn't figure out my issue. I will probably work with this some more in the not too distant future so if I figure anything out I will let you know.

Kevin
kmkocot is offline   Reply With Quote
Old 02-26-2013, 05:36 AM   #6
SES
Senior Member
 
Location: Vancouver, BC

Join Date: Mar 2010
Posts: 275
Default

If you are unable to connect it could mean that the MySQL daemon isn't running. You should be able to do something like:
Code:
ps axu | grep mysqld
to check. Depending on how you configured MySQL, it may not be set to start automatically. This is a common reason for not being able to connect.
SES is offline   Reply With Quote
Old 06-11-2014, 08:01 AM   #7
klduong
Junior Member
 
Location: Lexington, KY

Join Date: Nov 2012
Posts: 4
Default

Quote:
Originally Posted by rahularjun86 View Post
Hi All,
I am also getting an error in the 4th Step "orthomclInstallSchema"
HTML Code:
[rsharma@primary my_orthomcl_dir]$ orthomclInstallSchema orthomcl.config.template 
DBI connect('orthomcl:3307','orthomcl',...) failed: Can't connect to MySQL server on '3307' (22) at /home/rsharma/Software/orthomclSoftware-v2.0.3/bin/../lib/perl/OrthoMCLEngine/Main/Base.pm line 56.
Can't connect to MySQL server on '3307' (22) at /home/rsharma/Software/orthomclSoftware-v2.0.3/bin/../lib/perl/OrthoMCLEngine/Main/Base.pm line 56, <F> line 14.
I did the mysql installations on my home directory without su privileges. I would really appreciate if someone could help me out.
Regards,
Rahul

Even though this is an old post (and probably way too late for rahularjun86), I wanted to share my solution for other users (I spent too much time on this nonsense!).

Run netstat -tanp | grep mysqld
You should get something along the lines of:
tcp 0 0 0.0.0.0:#### 0.0.0.0:* LISTEN #####/mysqld

The #####/mysqld is the PID number--you don't care about this.
The number listed at 0.0.0.0:#### is the port number. This is what should be in orthomcl.config. For me it was set at 3306--the default port and what is assumed in orthomcl.config.template is 3307.
klduong is offline   Reply With Quote
Old 11-10-2015, 08:29 PM   #8
akhilv
Junior Member
 
Location: india

Join Date: Nov 2015
Posts: 1
Default

I got same issue while running orthomcl load blast
"DBI connect('orthomcl:3307','root',...) failed: Can't connect to MySQL server on '3307' (22) at /home/eprints/clust/orthomclSoftware/bin/../lib/perl/OrthoMCLEngine/Main/Base.pm line 56.''

how to solve this?
akhilv is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 05:37 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO