SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unknown error with Stampy vivi7 Bioinformatics 2 08-16-2016 12:46 AM
error in Trimmomatic command Sharmi General 3 04-16-2016 06:36 AM
Trimmomatic error Saeideh Bioinformatics 6 09-13-2015 07:10 AM
Trimmomatic error dvanic Bioinformatics 31 04-06-2015 01:24 AM

Reply
 
Thread Tools
Old 03-01-2017, 10:32 AM   #1
BioBing
Junior Member
 
Location: Denmark

Join Date: Mar 2017
Posts: 3
Default Trimmomatic - unknown trimmer error?

Hi all,

I am really struggling with Trimmomatic these days and the frustration level is rising (I have to meet a deadline). For multiple days Trimmomatic, on usegalaxy.org, has given me an error as soon as I apply the IlluminaClip:

Quote:
Fatal error: Exit code 1 () Trimmomatic did not finish successfully
It works like a charm when applying the options for quality trimming, head-crop etc. I reported the error a few days ago, but it is still not working. In order to move along, I installed Trimmomatic on my computer (mac OS Sierra) through the homebrew/science command line application.

When I run Trimmomatic, I continue to get an "unknown trimmer" error and cannot figure out how to fix it. Usage of command line and coding are still fairly new to me.

I have applied following in the folder where the data is:

Code:
 
ENSPAC1515:01_Raw_data user$ 
Trimmomatic PE -trimlog L001_adapter.txt  
-basein Reference-Sample-index27_S1_L001_R1_001.fastq.gz 
Reference-Sample-index27_S1_L001_R2_001.fastq.gz 
-baseout L001_adapter_R1_P.fastq.gz L001_adapter_R1_U.fastq.gz
L001_adapter_R2_P.fastq.gz L001_adapter_R2_U.fastq.gz 
ILLUMINACLIP: TruSeq3-PE.fa:2:40:15
And this happens:

Code:
TrimmomaticPE: Started with arguments:
-trimlog L001_adapter.txt 
-basein Reference-Sample-index27_S1_L001_R1_001.fastq.gz 
           Reference-Sample-index27_S1_L001_R2_001.fastq.gz
-baseout L001_adapter_R1_P.fq.gz 
              L001_adapter_R1_U.fq.gz 
              L001_adapter_R2_P.fq.gz 
              L001_adapter_R2_U.fq.gz 
ILLUMINACLIP: TruSeq3-PE.fa:2:40:15

Multiple cores found: Using 4 threads

Using templated Input files: 
Reference-Sample-index27_S1_L001_R1_001.fastq.gz 
Reference-Sample-index27_S1_L001_R2_001.fastq.gz

Using templated Output files: 
L001_adapter_R1_P_1P.fq.gz L001_adapter_R1_P_1U.fq.gz
L001_adapter_R1_P_2P.fq.gz L001_adapter_R1_P_2U.fq.gz

Exception in thread "main" java.lang.RuntimeException: Unknown trimmer: 
Reference-Sample-index27_S1_L001_R2_001.fastq.gz

at org.usadellab.trimmomatic.trim.TrimmerFactory.makeTrimmer
(TrimmerFactory.java:70)
at org.usadellab.trimmomatic.Trimmomatic.createTrimmers
(Trimmomatic.java:59)
at org.usadellab.trimmomatic.TrimmomaticPE.run
(TrimmomaticPE.java:536)
at org.usadellab.trimmomatic.Trimmomatic.main
(Trimmomatic.java:80)
I also tried to download the Truseq3-PE.fa and use the path to it in the Illuminaclip (but I get the same error). Hopefully some of you, know how to fix this? You will save my day if you do

Thank you!!
BioBing is offline   Reply With Quote
Old 03-01-2017, 01:24 PM   #2
mastal
Senior Member
 
Location: uk

Join Date: Mar 2009
Posts: 667
Default

Remove '-basein' and '-baseout', and leave the rest of your command the way it is, I think it should then work. When you specify the full names of all the input and output files, you don't need to use -basein and -baseout.
mastal is offline   Reply With Quote
Old 03-01-2017, 01:31 PM   #3
BioBing
Junior Member
 
Location: Denmark

Join Date: Mar 2017
Posts: 3
Default

Hi Mastal,

Thank you so much for responding. I tried as you suggested, but it is still not working

Code:
java -jar trimmomatic-0.36.jar PE –trimlog logfile L001_R1.fastq L001_R2.fastq L001_R1_P.fastq L001_R1_U.fastq L001_R2_P.fastq L001_R2_U.fastq ILLUMINACLIP:TruSeq3-PE.fa:2:40:15
Code:
TrimmomaticPE: Started with arguments:
 –trimlog logfile L001_R1.fastq L001_R2.fastq L001_R1_P.fastq L001_R1_U.fastq L001_R2_P.fastq L001_R2_U.fastq ILLUMINACLIP:TruSeq3-PE.fa:2:40:15
Multiple cores found: Using 4 threads
Exception in thread "main" java.lang.RuntimeException: Unknown trimmer: L001_R2_P.fastq
	at org.usadellab.trimmomatic.trim.TrimmerFactory.makeTrimmer(TrimmerFactory.java:70)
	at org.usadellab.trimmomatic.Trimmomatic.createTrimmers(Trimmomatic.java:59)
	at org.usadellab.trimmomatic.TrimmomaticPE.run(TrimmomaticPE.java:536)
	at org.usadellab.trimmomatic.Trimmomatic.main(Trimmomatic.java:80)
I have no idea what is the issue. This time I tried directly with the java file.
BioBing is offline   Reply With Quote
Old 03-01-2017, 01:55 PM   #4
BioBing
Junior Member
 
Location: Denmark

Join Date: Mar 2017
Posts: 3
Default

I solved it!!!

I deleted the -trimlog part, and suddenly it worked!

This is the code I used, in case others have similar issues:

I solved it! By deleting -trimlog, -inbase and -outbase - as well as found a space that should not be there, it worked!

In case others have the same issue, this is how my code looked like (this time I used the homebrew version):

Quote:
Trimmomatic PE L001_R1.fastq L001_R2.fastq out_L001_R1_P.fastq out_L001_R1_U.fastq out_L001_R2_P.fastq L001_R2_U.fastq ILLUMINACLIP:TruSeq3-PE.fa:2:40:15
BioBing is offline   Reply With Quote
Reply

Tags
preprocessing, rna-seq analysis, trimming reads, trimmomatic

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 06:23 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO