SEQanswers

Go Back   SEQanswers > Applications Forums > RNA Sequencing



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tophat: segment-based junction search failed with err =-11 jdanderson Bioinformatics 15 10-14-2017 06:47 AM
Tophat error -segment-based junction search failled with err=1 upadhyayanm Bioinformatics 24 06-21-2016 06:20 PM
segment-based junction search failed Wei-HD Bioinformatics 6 07-18-2013 02:58 AM
yet another "Error: segment-based junction search failed with err = -9" liux Bioinformatics 1 08-24-2010 09:48 AM
Error: segment-based junction search failed with err = -9 Albert Cheng Bioinformatics 1 08-19-2010 08:24 AM

Reply
 
Thread Tools
Old 07-20-2011, 06:50 AM   #1
sjnewhouse
Junior Member
 
Location: London

Join Date: Apr 2010
Posts: 1
Default Tophat Error: Error: segment-based junction search failed with err =-6

Hi All,
I'm running into problems with Tophat; keep getting the following error:-
Error: segment-based junction search failed with err =-6.
This is HiSeq 100bp PE data.
Any ideas?
Cheers
Steve
##
[Mon Jul 18 16:27:43 2011] Beginning TopHat run (v1.3.1)
-----------------------------------------------
[Mon Jul 18 16:27:43 2011] Preparing output location ./AST1.chr.9.tiling.bicep.smooth.muscle.july.2011/
[Mon Jul 18 16:27:43 2011] Checking for Bowtie index files
[Mon Jul 18 16:27:43 2011] Checking for reference FASTA file
[Mon Jul 18 16:27:43 2011] Checking for Bowtie
Bowtie version: 0.12.7.0
[Mon Jul 18 16:27:43 2011] Checking for Samtools
Samtools Version: 0.1.15
[Mon Jul 18 16:27:43 2011] Generating SAM header for /scratch/data/reference_genomes/human/human_g1k_v37
[Mon Jul 18 16:28:02 2011] Preparing reads
format: fastq
quality scale: phred33 (default)
[Mon Jul 18 16:28:02 2011] Reading known junctions from GTF file
Left reads: min. length=100, count=151802002
Right reads: min. length=100, count=151646210
[Mon Jul 18 19:11:17 2011] Mapping left_kept_reads against human_g1k_v37 with Bowtie
[Mon Jul 18 21:11:50 2011] Processing bowtie hits
[Mon Jul 18 23:05:38 2011] Mapping left_kept_reads_seg1 against human_g1k_v37 with Bowtie (1/4)
[Tue Jul 19 02:45:12 2011] Mapping left_kept_reads_seg2 against human_g1k_v37 with Bowtie (2/4)
[Tue Jul 19 06:18:55 2011] Mapping left_kept_reads_seg3 against human_g1k_v37 with Bowtie (3/4)
[Tue Jul 19 09:49:52 2011] Mapping left_kept_reads_seg4 against human_g1k_v37 with Bowtie (4/4)
[Tue Jul 19 13:22:18 2011] Mapping right_kept_reads against human_g1k_v37 with Bowtie
[Tue Jul 19 15:00:03 2011] Processing bowtie hits
[Tue Jul 19 16:53:27 2011] Mapping right_kept_reads_seg1 against human_g1k_v37 with Bowtie (1/4)
[Tue Jul 19 21:01:46 2011] Mapping right_kept_reads_seg2 against human_g1k_v37 with Bowtie (2/4)
[Wed Jul 20 00:52:22 2011] Mapping right_kept_reads_seg3 against human_g1k_v37 with Bowtie (3/4)
[Wed Jul 20 04:31:58 2011] Mapping right_kept_reads_seg4 against human_g1k_v37 with Bowtie (4/4)
[Wed Jul 20 08:07:07 2011] Searching for junctions via segment mapping
[FAILED]
Error: segment-based junction search failed with err =-6
sjnewhouse is offline   Reply With Quote
Old 10-12-2011, 07:28 AM   #2
curtish
Junior Member
 
Location: UAB (Birmingham, AL, USA)

Join Date: Oct 2011
Posts: 2
Default

Any resolution to this? We're seeing the same error on HiSeq PE 50bp data - but only on some data sets (always the same reference genome). It's consistent for a particular read set - either always failing or always working.

Note: we're on 1.2.0, you're on 1.3.1.


Quote:
Tue Oct 11 14:27:13 2011] Beginning TopHat run (v1.2.0)
-----------------------------------------------
[Tue Oct 11 14:27:13 2011] Preparing output location ./tophat_out/
[Tue Oct 11 14:27:13 2011] Checking for Bowtie index files
[Tue Oct 11 14:27:13 2011] Checking for reference FASTA file
[Tue Oct 11 14:27:13 2011] Checking for Bowtie
Bowtie version: 0.12.7.0
[Tue Oct 11 14:27:13 2011] Checking for Samtools
Samtools Version: 0.1.12a
[Tue Oct 11 14:27:43 2011] Checking reads
min read length: 51bp, max read length: 51bp
format: fastq
quality scale: phred33 (default)
[Tue Oct 11 14:57:03 2011] Mapping reads against dataset_4371 with Bowtie
[Tue Oct 11 15:41:43 2011] Joining segment hits
[Tue Oct 11 15:59:13 2011] Mapping reads against dataset_4371 with Bowtie(1/2)
[Tue Oct 11 16:49:19 2011] Mapping reads against dataset_4371 with Bowtie(2/2)
[Tue Oct 11 17:31:34 2011] Mapping reads against dataset_4371 with Bowtie
[Tue Oct 11 18:14:46 2011] Joining segment hits
[Tue Oct 11 18:31:31 2011] Mapping reads against dataset_4371 with Bowtie(1/2)
[Tue Oct 11 19:25:04 2011] Mapping reads against dataset_4371 with Bowtie(2/2)
[Tue Oct 11 20:09:42 2011] Searching for junctions via segment mapping
[FAILED]
Error: segment-based junction search failed with err = -6
curtish is offline   Reply With Quote
Old 11-05-2011, 04:59 AM   #3
mauro.pala
Junior Member
 
Location: italy

Join Date: Jun 2011
Posts: 4
Default

have someone solved this issue? I am having the same error


~45M of reads PE, Bowtie 0.12.7.0, TopHat v1.3.1, samtools-0.1.16, reference g1k_v37




[Sat Nov 5 02:47:34 2011] Beginning TopHat run (v1.3.1)
-----------------------------------------------
[Sat Nov 5 02:47:34 2011] Preparing output location ./
[Sat Nov 5 02:47:34 2011] Checking for Bowtie index files
[Sat Nov 5 02:47:34 2011] Checking for reference FASTA file
[Sat Nov 5 02:50:50 2011] Checking for Bowtie
Bowtie version: 0.12.7.0
[Sat Nov 5 02:50:50 2011] Checking for Samtools
Samtools Version: 0.1.16
[Sat Nov 5 02:50:50 2011] Generating SAM header for /SHARE/USERFS/els6/users/mpala/annotation/NCBI/human_g1k_v37/bowtie_index/genome
[Sat Nov 5 02:53:01 2011] Preparing reads
format: fastq
quality scale: phred33 (default)
[Sat Nov 5 02:53:01 2011] Reading known junctions from GTF file
Left reads: min. length=36, count=43896506
Right reads: min. length=38, count=43849406
[Sat Nov 5 03:20:08 2011] Mapping left_kept_reads against genome with Bowtie
[Sat Nov 5 04:03:32 2011] Processing bowtie hits
[Sat Nov 5 04:42:00 2011] Mapping left_kept_reads_seg1 against genome with Bowtie (1/2)
[Sat Nov 5 05:15:39 2011] Mapping left_kept_reads_seg2 against genome with Bowtie (2/2)
[Sat Nov 5 05:49:00 2011] Mapping right_kept_reads against genome with Bowtie
[Sat Nov 5 06:28:18 2011] Processing bowtie hits
[Sat Nov 5 07:08:43 2011] Mapping right_kept_reads_seg1 against genome with Bowtie (1/2)
[Sat Nov 5 07:53:55 2011] Mapping right_kept_reads_seg2 against genome with Bowtie (2/2)
[Sat Nov 5 08:46:16 2011] Searching for junctions via segment mapping
[FAILED]
Error: segment-based junction search failed with err =-6


M.
mauro.pala is offline   Reply With Quote
Old 11-17-2011, 07:22 AM   #4
biznatch
Senior Member
 
Location: Canada

Join Date: Nov 2010
Posts: 126
Default Out of memory?

I'm getting the same error. I'm using the command

Code:
tophat -p 6 --butterfly-search --no-convert-bam ~/chip/bowtie/indexes/mm9all+ ~/chip/data/E14_c_reads1.fastq ~/chip/data/E14_c_reads2.fastq
The index I'm using is the mm9 mouse genome including all the "unknown" and "random" chromosomes plus I've added in about 1kb of custom sequence.

Code:
[Wed Nov 16 23:58:28 2011] Beginning TopHat run (v1.3.3)
-----------------------------------------------
[Wed Nov 16 23:58:28 2011] Preparing output location ./tophat_out/
[Wed Nov 16 23:58:28 2011] Checking for Bowtie index files
[Wed Nov 16 23:58:28 2011] Checking for reference FASTA file
[Wed Nov 16 23:58:28 2011] Checking for Bowtie
	Bowtie version:			 0.12.7.0
[Wed Nov 16 23:58:28 2011] Checking for Samtools
	Samtools Version: 0.1.18
[Wed Nov 16 23:58:28 2011] Generating SAM header for /home/mike/chip/bowtie/indexes/mm9all+
[Wed Nov 16 23:58:31 2011] Preparing reads
	format:		 fastq
	quality scale:	 phred33 (default)
	Left  reads: min. length=100, count=33713874
	Right reads: min. length=100, count=33708045
[Thu Nov 17 00:27:42 2011] Mapping left_kept_reads against mm9all+ with Bowtie 
[Thu Nov 17 00:56:53 2011] Processing bowtie hits
[Thu Nov 17 01:24:46 2011] Mapping left_kept_reads_seg1 against mm9all+ with Bowtie (1/4)
[Thu Nov 17 01:57:03 2011] Mapping left_kept_reads_seg2 against mm9all+ with Bowtie (2/4)
[Thu Nov 17 02:29:33 2011] Mapping left_kept_reads_seg3 against mm9all+ with Bowtie (3/4)
[Thu Nov 17 03:04:10 2011] Mapping left_kept_reads_seg4 against mm9all+ with Bowtie (4/4)
[Thu Nov 17 03:35:00 2011] Mapping right_kept_reads against mm9all+ with Bowtie 
[Thu Nov 17 04:02:48 2011] Processing bowtie hits
[Thu Nov 17 04:30:51 2011] Mapping right_kept_reads_seg1 against mm9all+ with Bowtie (1/4)
[Thu Nov 17 05:06:11 2011] Mapping right_kept_reads_seg2 against mm9all+ with Bowtie (2/4)
[Thu Nov 17 05:42:10 2011] Mapping right_kept_reads_seg3 against mm9all+ with Bowtie (3/4)
[Thu Nov 17 06:20:41 2011] Mapping right_kept_reads_seg4 against mm9all+ with Bowtie (4/4)
[Thu Nov 17 06:54:57 2011] Searching for junctions via segment mapping
	[FAILED]
Error: segment-based junction search failed with err =-6
In the log file "segment_juncs.log" it ends with:

Code:
>> Performing butterfly-search: 
Recording coverage islands
Found 11562195 islands covering 532250647 bases
Collecting potential splice sites in islands
terminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc
"std::bad_alloc" seems to mean you've run out of memory, and I was running without a swap file (although I have 16GB RAM) so that could have been the problem, also maybe butterfly-search uses more memory? It was running overnight so I wasn't watching it at the time. I'll try with swap and without butterfly search and see if that works. To the other people having this problem, check the log files in the "logs" folder in the "tophat_out" folder, in particular the "segment_juncs.log" file which should be the last one that was created.

Last edited by biznatch; 11-17-2011 at 07:27 AM.
biznatch is offline   Reply With Quote
Old 02-26-2013, 11:54 PM   #5
Jane Lee
Junior Member
 
Location: China

Join Date: Feb 2013
Posts: 6
Default ask for solutions for the same problem

Quote:
Originally Posted by curtish View Post
Any resolution to this? We're seeing the same error on HiSeq PE 50bp data - but only on some data sets (always the same reference genome). It's consistent for a particular read set - either always failing or always working.

Note: we're on 1.2.0, you're on 1.3.1.

HI, have you solved the problem already? If so, could you give me some advice, for I met the same problem when running tophat.

Thank you very much!
Best wishes!
Jane Lee is offline   Reply With Quote
Old 02-27-2013, 12:44 AM   #6
DonDolowy
Member
 
Location: Freiburg

Join Date: Oct 2012
Posts: 56
Default

I had the same problem with two out of 32 samples I mapped. I never figured out what was causing it, but updating TopHat to the most recent version (2.0.8) solved the problem.
DonDolowy is offline   Reply With Quote
Old 02-27-2013, 04:53 PM   #7
Jane Lee
Junior Member
 
Location: China

Join Date: Feb 2013
Posts: 6
Default Thank you but I ran into a new problem

Quote:
Originally Posted by DonDolowy View Post
I had the same problem with two out of 32 samples I mapped. I never figured out what was causing it, but updating TopHat to the most recent version (2.0.8) solved the problem.
Thank you.

I installed the new tophat v2.0.8, and built new bowtie2 index and ran my sample again with the same command line order:
tophat -p 8 -G Homo_sapiens.GRCh37.68.gtf -o 22_thout genome 22-1.fastq 22-2.fastq

but I got another error here:
2013-02-28 09:16:30] Beginning TopHat run (v2.0.8)
-----------------------------------------------
[2013-02-28 09:16:30] Checking for Bowtie
Bowtie version: 2.0.5.0
[2013-02-28 09:16:30] Checking for Samtools
Samtools version: 0.1.18.0
[2013-02-28 09:16:30] Checking for Bowtie index files
Warning: we do not recommend to have both Bowtie1 and Bowtie2 indexes in the same directory
the genome sequence (*.fa) may not be compatible with one of them
[2013-02-28 09:16:30] Checking for reference FASTA file
[2013-02-28 09:16:30] Generating SAM header for /media/RAID/work/lixinna/raw_data/2012-08-16-tumor-RNA-seq/experiment/genome
format: fastq
quality scale: phred33 (default)
[2013-02-28 09:16:32] Reading known junctions from GTF file
[2013-02-28 09:16:43] Preparing reads
[FAILED]
Error running 'prep_reads'
prep_reads [--filter-multi <multi.fq>] <reads1.fa/fq,...,readsN.fa/fq>

I still can't figure out the solution, could you give me some advice?

Thank you in advance.
Jane Lee is offline   Reply With Quote
Old 03-12-2013, 02:16 PM   #8
darya
Junior Member
 
Location: canada

Join Date: Mar 2012
Posts: 1
Default

Hi there,

I had the same problem with my samples and figured it is just a memory issue.
If you are running tophat with option -coverage-search on, you need more than 40 GB of RAM available to tophat.
However, If your read length is > 48bp, you do not need coverage search. Turn it off by --no-coverage-search in your command. Tophat works much faster and with no error. :-)

Good luck,
darya is offline   Reply With Quote
Old 03-19-2013, 04:14 AM   #9
Jane Lee
Junior Member
 
Location: China

Join Date: Feb 2013
Posts: 6
Smile

Quote:
Originally Posted by darya View Post
Hi there,

I had the same problem with my samples and figured it is just a memory issue.
If you are running tophat with option -coverage-search on, you need more than 40 GB of RAM available to tophat.
However, If your read length is > 48bp, you do not need coverage search. Turn it off by --no-coverage-search in your command. Tophat works much faster and with no error. :-)

Good luck,
Hi there,

Thank you very much.

I update the tophat version and the problem dispearred.

So it may be a bug.
Jane Lee is offline   Reply With Quote
Reply

Tags
error, junction search failed, tophat

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 05:22 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO