SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tophat for single end reads lynn012 RNA Sequencing 20 10-27-2014 09:04 PM
50 bp paired end reads vs. 100 bp single end reads efoss Bioinformatics 12 01-15-2014 08:05 PM
TopHat -paired end vs single end reads adarshjose RNA Sequencing 10 06-12-2012 06:15 PM
Tophat command for single end reads kasutubh Bioinformatics 1 09-24-2011 02:30 AM
does tophat rescue PE reads that do not map by aligning a single end of the PE? zorph Bioinformatics 0 09-09-2011 02:14 PM

Reply
 
Thread Tools
Old 04-13-2011, 07:02 AM   #1
adrian
Member
 
Location: baltimore

Join Date: Oct 2009
Posts: 89
Default tophat - r option - single end reads

Hi:

I have GAII data - 36 bp single end reads.

I am using tophat following option

tophat -p 14 btie/indexes/hg18 sample1.fastq -o awb --segment-mismatches 3

Error: you must set the mean inner distance between mates with -r


I get the error forcing me to set -r option. These reads are single-end reads, why tophat wants me to set -r.

can I instead set -r 0?
any help appreciated.

thanks
Adrian
adrian is offline   Reply With Quote
Old 05-26-2011, 09:23 PM   #2
kreitinger
Member
 
Location: Madison, WI

Join Date: May 2011
Posts: 10
Default Same Issue

I am trying to map 42 bp single reads and have the same error message.
kreitinger is offline   Reply With Quote
Old 05-28-2011, 06:33 PM   #3
DZhang
Senior Member
 
Location: East Coast, US

Join Date: Jun 2010
Posts: 177
Default

Hi

Please check if you are using the latest version of tophat. I did one project 2 months ago using Tophat on single-fragment reads and it worked. My actual command was

tophat -p 6 --allow-indels -o $id $ref $id.fq

Hope it helps.

Douglas
www.contigexpress.com
DZhang is offline   Reply With Quote
Old 06-07-2011, 08:25 AM   #4
vineeth_s
Junior Member
 
Location: Germany

Join Date: Jun 2011
Posts: 9
Default

For SOLiD reads, you have to put the -Q option in the list of options, and specify the _QV.qual file at the end after the reads file, like so:

tophat -C -Q -G reference.gtf reads_filename.csfasta reads_filename_QV.qual
vineeth_s is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 12:56 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO