SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
TopHat Error: Could not find Bowtie index files /bowtie-0.12.5/indexes/. rebrendi Bioinformatics 11 06-22-2016 09:55 AM
Bowtie...Error: could not execute Bowtie Brajbio Bioinformatics 6 02-12-2013 01:01 PM
Bowtie memory error polsum Bioinformatics 2 12-02-2011 12:17 PM
Bowtie Error Message cutcopy11 Bioinformatics 1 06-24-2011 12:28 AM
bowtie error "Error reading _offs[] array: " Nicolas902 Bioinformatics 5 08-27-2010 08:02 AM

Reply
 
Thread Tools
Old 10-05-2010, 05:45 AM   #1
jamal
Member
 
Location: Denmark

Join Date: Jan 2010
Posts: 10
Default bowtie error

hi all,

I am trying to use Bowtie to align paired end sequencing data from solexa, I made indexfiles, and run bowtie for my files by this command:

bowtie -S -a -v 3 -q -I 0 - X 400 -t /mgs/.../Assembled_chromosomes/renames/Allchro -1 /mgs/.../Sequences_original_08-09/s_1_1_sequence.txt -2 /mgs/.../Sequences_original_08-09/s_1_2_sequence.txt s_1_bowt.sam

read length=101, size of fragment=400bp

but I am consistently getting this:

Extra parameter(s) specified: "400", "/mgs/....../renames/Allchro", "s_1_seq_pe_bowt_101_3mis.sam"
Note that if <mates> files are specified using -1/-2, a <singles> file cannot
also be specified. Please run bowtie separately for mates and singles.
Overall time: 00:00:00

Does anyone have any ideas as to what I should do?

Last edited by jamal; 10-06-2010 at 06:27 AM.
jamal is offline   Reply With Quote
Old 10-05-2010, 06:06 AM   #2
VIB_user
Junior Member
 
Location: belgium

Join Date: Oct 2010
Posts: 7
Default

i used bowtie
and all i used in my query was a .txt file (that was fastq result) and then the indexes that i downloaded from the site

bowtie -S mm9 ../100920_s_1_seq_GLJ-1.txt mm9_snp_1_1.sam

like this
were -S specifice that i use samtools and mm9 = my indexfiles and the txt file is my fastq file and the .sam = output
VIB_user is offline   Reply With Quote
Old 10-05-2010, 07:30 AM   #3
Ben Langmead
Senior Member
 
Location: Baltimore, MD

Join Date: Sep 2008
Posts: 200
Default

Quote:
Originally Posted by jamal View Post
hi all,

bowtie -S -a -v 3 -q -I 0 - X 400 -t /mgs/.../Assembled_chromosomes/renames/Allchro -1 /mgs/.../Sequences_original_08-09/s_1_1_sequence.txt -2 /mgs/.../Sequences_original_08-09/s_1_2_sequence.txt s_1_bowt.sam

Extra parameter(s) specified: "400",
Hi Jamal,

Looks like there's a space between "-" and "X" in the "- X 400" part of your command. If you remove the space ("-X 400"), I think the command should work.

Thanks,
Ben
Ben Langmead is offline   Reply With Quote
Old 10-05-2010, 09:04 AM   #4
jamal
Member
 
Location: Denmark

Join Date: Jan 2010
Posts: 10
Default

Quote:
Originally Posted by Ben Langmead View Post
Hi Jamal,

Looks like there's a space between "-" and "X" in the "- X 400" part of your command. If you remove the space ("-X 400"), I think the command should work.

Thanks,
Ben
Thank you Ben.
I also put my index in current directory , and it worked.
thanks again.
jamal is offline   Reply With Quote
Reply

Tags
alignment tool, bowtie, command, paired end

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 01:15 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO