SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
HaloPlex for library preparation ycding Sample Prep / Library Generation 3 05-22-2013 04:46 AM
Looking for some Haloplex Exome data BLASTphemy General 0 04-17-2013 01:00 PM
Adapter trimming and trimming by quality question alisrpp Bioinformatics 5 04-08-2013 04:55 PM
HaloPlex Updates loretta.manning Sample Prep / Library Generation 0 06-22-2012 10:28 AM
Haloplex for Ion Torrent lau83 Ion Torrent 2 06-19-2012 09:52 PM

Reply
 
Thread Tools
Old 07-23-2013, 12:35 AM   #1
jordi
Member
 
Location: València, Spain

Join Date: Apr 2009
Posts: 48
Default Trimming Haloplex adapters

Hi everyone!
I am trying to trim resulting amplicon reads from Haloplex and sequenced with MiSeq.
I've found some information : http://seqanswers.com/forums/showthr...light=haloplex. In fact, the user swNGS says that he have a well defined protocol to trim those sequences. However, I've just found a technical note from Illumina (Mutation Detection and CNV Analysis
for Illumina Sequencing data from HaloPlex Target Enrichment Panels using NextGENe Software for Clinical Research) reagrding the NextGene software, saying that there is no 5' adapter sequences and just a pair of 3' sequences.
As far as I know, the resulting amplicons from HaloPlex are constructions like:
PCR_primer-----Illumina_adaptor-----target-----Illumina_adaptor-----Barcode-----PCR_primer
Should I trim just by Illumina adaptors or PCR_primers should be removed too??
Any advice will be appreciate!
jordi is offline   Reply With Quote
Old 07-23-2013, 07:20 AM   #2
adamdeluca
Member
 
Location: Iowa City, IA

Join Date: Jul 2010
Posts: 95
Default

I used cutadapt (https://code.google.com/p/cutadapt/) for trimming. I needed to include the barcode and primers in the trimmed sequence because of how poorly my haloplex experiment worked. Hope this helps.

python cutadapt -a GATCGGAAGAGCACACGTCTGAACTCCAGTCACATGCCTAACTCGTATGCCGTCTTCTGCTTG infile_1.fastq > outfile_1.fastq

python cutadapt -a AGATCGGAAGAGCGTCGTGTAGGGAAAGAGTGTAGATCTCGGTGGTCGCCGTATCATT infile_2.fastq > outfile_2.fastq

Forward Sequence:
GATCGGAAGAGCACACGTCTGAACTCCAGTCAC
[barcode]
CTCGTATGCCGTCTTCTGCTTG

Reverse Sequence:
AGATCGGAAGAGCGTCGTGTAGGGAAAGAGTGTAGATCTCGGTGGTCGCCGTATCATT
adamdeluca is offline   Reply With Quote
Old 07-23-2013, 08:05 AM   #3
jordi
Member
 
Location: València, Spain

Join Date: Apr 2009
Posts: 48
Default

Thank you so much adamdeluca. That's is exactly what I was looking for, a pair of sequences to be trimmed. I will try trimmomatic and cutadapt in order to find differences!
jordi is offline   Reply With Quote
Old 08-08-2013, 10:01 AM   #4
id0
Senior Member
 
Location: USA

Join Date: Sep 2012
Posts: 130
Default

According to the official Agilent instructions:
Quote:
Example using HaloPlex Illumina Data:
cutadapt -a AGATCGGAAGAGCACACGTCTGAACTCCAGTCAC mate1.fastq \
-o mate1.trimmed.fastq;
cutadapt -a AGATCGGAAGAGCGTCGTGTAGGGAAAGAGTGTAGATCTCGGTGGTCGCCGTATCATT \
mate2.fastq -o mate2.trimmed.fastq;
Not sure why R1 sequence differs from adamdeluca's answer.
id0 is offline   Reply With Quote
Old 08-20-2013, 02:18 PM   #5
adamdeluca
Member
 
Location: Iowa City, IA

Join Date: Jul 2010
Posts: 95
Default

My sequence differed because I was seeing reads into the barcodes.
adamdeluca is offline   Reply With Quote
Old 01-02-2014, 11:13 AM   #6
rsanghvi
Junior Member
 
Location: Houston, Tx

Join Date: Jan 2014
Posts: 3
Default

Hi,

After trimming the Fastq reads according to :
"Example using HaloPlex Illumina Data:
cutadapt -a AGATCGGAAGAGCACACGTCTGAACTCCAGTCAC mate1.fastq \
-o mate1.trimmed.fastq;
cutadapt -a AGATCGGAAGAGCGTCGTGTAGGGAAAGAGTGTAGATCTCGGTGGTCGCCGTATCATT \
mate2.fastq -o mate2.trimmed.fastq;"

Do you see occurrences where the whole read sequence has been trimmed? I am seeing this kind of occurrence which causes issues while mapping since there is no read in mate1.fastq and there is in mate2.fastq.

Any help would be greatly appreciated.
rsanghvi is offline   Reply With Quote
Old 01-02-2014, 11:42 AM   #7
adamdeluca
Member
 
Location: Iowa City, IA

Join Date: Jul 2010
Posts: 95
Default

Quote:
Originally Posted by rsanghvi View Post
Hi,
Do you see occurrences where the whole read sequence has been trimmed?
Yes, I saw a great number of fragments with no insert at all.
adamdeluca is offline   Reply With Quote
Old 01-02-2014, 11:48 AM   #8
rsanghvi
Junior Member
 
Location: Houston, Tx

Join Date: Jan 2014
Posts: 3
Default

Oh ok. (Atleast i am not doing anything wrong)

So how did you overcome that issue in order to map?

So is it better to specify a minimum size of the read to be kept in the output files and also use the --paired-end option in cutadapt to keep the entries similar in both read files.

Please let me know if there is any other way to overcome this issue.
rsanghvi is offline   Reply With Quote
Old 01-02-2014, 11:52 AM   #9
adamdeluca
Member
 
Location: Iowa City, IA

Join Date: Jul 2010
Posts: 95
Default

Quote:
Originally Posted by rsanghvi View Post
So how did you overcome that issue in order to map?
I didn't have the issue, if there is no insert, both reads in the pair should trim to nothing. Mine did at least.

Good luck
adamdeluca is offline   Reply With Quote
Old 01-02-2014, 11:49 PM   #10
jordi
Member
 
Location: València, Spain

Join Date: Apr 2009
Posts: 48
Default

Hi,
I found the same issue working with those data.
According to my opinion, setting a minimum read lenght should be included in he management of NGS data. However, I fix the problem using Trim galore software (http://www.bioinformatics.babraham.a...s/trim_galore/) which uses cutadapt, too.
From a certain customer service I got advice of using cutadapt first and then trim galore to resynchronize R1 and R2 fastq files since some reads might drop out during Cutadapt. In fact, using just Trim galore with the option "do not output unpaired reads” is a good way to proceed.
I hope this helps.
jordi is offline   Reply With Quote
Old 01-03-2014, 05:41 AM   #11
rsanghvi
Junior Member
 
Location: Houston, Tx

Join Date: Jan 2014
Posts: 3
Default

Hi Jordi,

Thank you for the information. This definitely helps.
This sounds like the --paired-end option in cutadapt.

But will give both a try.

Thanks.
rsanghvi is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 09:00 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO