SEQanswers

Go Back   SEQanswers > Applications Forums > RNA Sequencing



Similar Threads
Thread Thread Starter Forum Replies Last Post
DESeq2 Error nw328 Bioinformatics 9 02-13-2015 03:28 PM
DESeq2 design error evenstar Bioinformatics 1 02-10-2015 02:09 PM
DESeq2 error stormin Bioinformatics 6 09-08-2014 05:18 AM
DESeq2 error: varianceStabilizingTransformation error JonB Bioinformatics 7 11-22-2013 02:15 AM
Wired DESeq2 error sindrle Bioinformatics 5 10-25-2013 06:29 AM

Reply
 
Thread Tools
Old 10-17-2015, 08:41 AM   #1
Beemo
Junior Member
 
Location: Cardiff

Join Date: Mar 2015
Posts: 2
Default DESeq2 SummarizedExperiment0 Error

Hey,

So it's been a while since I used DESeq - I was trying to get DESeq2 working and I run into an error just attempting to run the example code from the vignette, running:

Quote:
directory <- system.file("extdata", package="pasilla", mustWork=TRUE)
sampleFiles <- grep("treated",list.files(directory),value=TRUE)
sampleCondition <- sub("(.*treated).*","\\1",sampleFiles)
sampleTable <- data.frame(sampleName = sampleFiles,
fileName = sampleFiles,
condition = sampleCondition)
ddsHTSeq <- DESeqDataSetFromHTSeqCount(sampleTable = sampleTable,
directory = directory,
design= ~ condition)
Gives me the following error:

Quote:
Error in initialize(value, ...) :
cannot use object of class “SummarizedExperiment0” in new(): class “DESeqDataSet” does not extend that class
My session info:

Quote:
R version 3.2.2 (2015-08-14)
Platform: x86_64-apple-darwin13.4.0 (64-bit)
Running under: OS X 10.10.5 (Yosemite)

locale:
[1] en_GB.UTF-8/en_GB.UTF-8/en_GB.UTF-8/C/en_GB.UTF-8/en_GB.UTF-8

attached base packages:
[1] parallel stats4 stats graphics grDevices utils datasets methods base

other attached packages:
[1] BiocInstaller_1.20.0 pasilla_0.10.0 DESeq2_1.10.0 RcppArmadillo_0.6.100.0.0 Rcpp_0.12.1 GenomicRanges_1.22.0 GenomeInfoDb_1.6.0 IRanges_2.4.0 S4Vectors_0.8.0
[10] BiocGenerics_0.16.0

loaded via a namespace (and not attached):
[1] RColorBrewer_1.1-2 futile.logger_1.4.1 plyr_1.8.3 XVector_0.10.0 futile.options_1.0.0 tools_3.2.2 zlibbioc_1.16.0 rpart_4.1-10
[9] digest_0.6.8 RSQLite_1.0.0 annotate_1.48.0 gtable_0.1.2 lattice_0.20-33 DBI_0.3.1 proto_0.3-10 gridExtra_2.0.0
[17] genefilter_1.52.0 stringr_1.0.0 cluster_2.0.3 locfit_1.5-9.1 nnet_7.3-11 grid_3.2.2 Biobase_2.30.0 AnnotationDbi_1.32.0
[25] XML_3.98-1.3 survival_2.38-3 BiocParallel_1.4.0 foreign_0.8-66 latticeExtra_0.6-26 Formula_1.2-1 geneplotter_1.48.0 ggplot2_1.0.1
[33] reshape2_1.4.1 lambda.r_1.1.7 magrittr_1.5 scales_0.3.0 Hmisc_3.17-0 MASS_7.3-44 splines_3.2.2 SummarizedExperiment_1.0.0
[41] xtable_1.7-4 colorspace_1.2-6 stringi_0.5-5 acepack_1.3-3.3 munsell_0.4.2

Any advice? Thanks!
Beemo is offline   Reply With Quote
Old 10-18-2015, 09:49 AM   #2
Michael Love
Senior Member
 
Location: Boston

Join Date: Jul 2013
Posts: 333
Default

Try restarting R. I think if you updated to the latest Bioc libs you might need a fresh start to get it working.
Michael Love is offline   Reply With Quote
Old 10-18-2015, 10:03 AM   #3
Beemo
Junior Member
 
Location: Cardiff

Join Date: Mar 2015
Posts: 2
Default

Damnit, yep that solved it, can't believe I hadn't tried that. Thanks!
Beemo is offline   Reply With Quote
Reply

Tags
bioconductor, deseq, rnaseq, summarizedexperiment

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 01:20 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO