SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Local BLAST installation on Linux lindashirley99 Bioinformatics 10 03-17-2014 03:08 AM
AMOS installation on 64-bit Linux agroster Bioinformatics 27 07-24-2013 01:31 PM
Cufflink-1.0.2 after version installation problem on Mac yh253 Bioinformatics 0 12-18-2011 06:21 AM
eagleview installation on linux litali Bioinformatics 0 07-20-2010 12:51 AM
GD installation on ia64 linux edge Bioinformatics 12 01-27-2010 01:59 AM

Reply
 
Thread Tools
Old 04-28-2010, 06:35 AM   #21
Utrecht
Junior Member
 
Location: Utrecht

Join Date: Apr 2010
Posts: 4
Default

I seem to be having the same problem. I am trying to install Cufflinks on a 32 bit Linux system, for which there are no pre-compiled binaries available (only 64 bit). I successfully built the Boost package using bjam, as instructed on the Getting Started page of Cufflinks.
Then I ran ./configure in the cufflinks directory, which gave no obvious errors (the Boost package was found, too). However, when I run 'make' there are several error messages that I don't understand (see below). Specially the '-m64' argument is suspicious, does this mean that it is trying to compile in 64 bit mode? I don't have enough experience with Linux to know how to proceed.
How did other people do this? Or is everyone using a 64 bit system? I have none available, as far as I know.
Any help would be greatly appreciated! Thanks..

Output after running 'make':
Code:
rob@robin:~/cufflinks-0.8.2$ make
make  all-recursive
make[1]: Entering directory `/home/robin/cufflinks-0.8.2'
Making all in src
make[2]: Entering directory `/home/robin/cufflinks-0.8.2/src'
if g++ -DHAVE_CONFIG_H -I. -I. -I..  -I../src    -Wall -Wno-strict-aliasing -g -gdwarf-2 -m64 -O3  -DNDEBUG  -pthread -I/usr/local/include -MT clustering.o -MD -MP -MF ".deps/clustering.Tpo" -c -o clustering.o clustering.cpp; \
	then mv -f ".deps/clustering.Tpo" ".deps/clustering.Po"; else rm -f ".deps/clustering.Tpo"; exit 1; fi
In file included from /usr/include/features.h:354,
                 from /usr/include/assert.h:37,
                 from /usr/include/c++/4.2/cassert:49,
                 from /usr/local/include/boost/graph/vector_as_graph.hpp:17,
                 from clustering.h:17,
                 from clustering.cpp:10:
/usr/include/gnu/stubs.h:9:27: error: gnu/stubs-64.h: No such file or directory
In file included from clustering.cpp:10:
clustering.h:29:41: error: boost/vector_property_map.hpp: No such file or directory
clustering.h:142:7: warning: no newline at end of file
make[2]: *** [clustering.o] Error 1
make[2]: Leaving directory `/home/robin/cufflinks-0.8.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/robin/cufflinks-0.8.2'
make: *** [all] Error 2
Utrecht is offline   Reply With Quote
Old 04-28-2010, 08:06 AM   #22
BioTalk
Member
 
Location: Kansas

Join Date: Feb 2010
Posts: 43
Default

I too experienced the same kind of problem with Cufflinks in 32 bit system. It was a problem because of 32 bit OS, as the binary available for 32 bit is getting compiled into 64bit and therefore it is of no use. I would suggest you to install cufflinks in 64 bit machine.

Thanks!
BioTalk is offline   Reply With Quote
Old 04-29-2010, 06:52 AM   #23
Utrecht
Junior Member
 
Location: Utrecht

Join Date: Apr 2010
Posts: 4
Default

Thanks BioTalk, unfortunately I don't have a 64 bit system available right now, so I'll have to think of something else...
Utrecht is offline   Reply With Quote
Old 06-15-2010, 01:29 AM   #24
repinementer
Member
 
Location: asia

Join Date: Dec 2009
Posts: 80
Default finding boost package in cufflinks

Hi all

The discussion is ended abruptly with out any answer
I was installed boost and bjam and built them on usr\local and after that ran ./configure but it is not detecting boost libraries.
i have added boost libraries to path also.

Then I ran ./configure in the cufflinks directory, which gave errors (the Boost package was not found).

PS:I'm using 32 bit computer and downloaded 32 bit boost packages

Code:
[bogugk@Trivia ~]$ cd /usr/local/boost_1_41_0/
[bogugk@Trivia boost_1_41_0]$ ls -l
total 320
drwxr-xr-x  3 root   root   4096 Jan  8 15:18 bin.v2
-rwxr-xr-x  1 root   root 171424 Jan  8 15:17 bjam
drwxr-xr-x 74    400  401  12288 Nov 18  2009 boost
-rw-r--r--  1    400  401    849 Nov 13  2009 boost-build.jam
-rw-r--r--  1    400  401    989 Nov 13  2009 boost.css
-rw-r--r--  1    400  401   6308 Nov 13  2009 boost.png
-rw-r--r--  1    400  401   1958 Nov 13  2009 bootstrap.bat
-rw-r--r--  1 root   root    852 Jan  8 15:17 bootstrap.log
-rwxr-xr-x  1    400  401  10211 Nov 13  2009 bootstrap.sh
-rw-r--r--  1    400  401    427 Nov 13  2009 CMakeLists.txt
drwxr-xr-x  7    400  401   4096 Nov 18  2009 doc
-rw-r--r--  1    400  401    770 Nov 13  2009 index.htm
-rw-r--r--  1    400  401   5485 Nov 13  2009 index.html
-rw-r--r--  1    400  401    291 Nov 13  2009 INSTALL
-rw-r--r--  1    400  401  23355 Nov 13  2009 Jamroot
drwxr-xr-x 85    400  401   4096 Nov 18  2009 libs
-rw-r--r--  1    400  401   1338 Nov 13  2009 LICENSE_1_0.txt
drwxr-xr-x  4    400  401   4096 Nov 18  2009 more
drwxr-xr-x  2    400  401   4096 Nov 18  2009 people
-rw-r--r--  1 root   root    822 Jan  8 15:17 project-config.jam
-rwxrwxrwx  1 gisv12  401   6009 Nov 18  2009 README.txt
-rw-r--r--  1    400  401   2610 Nov 13  2009 rst.css
drwxr-xr-x  3 root   root   4096 Jan  8 15:18 stage
drwxr-xr-x  2    400  401   4096 Nov 18  2009 status
drwxr-xr-x 13    400  401   4096 Nov 18  2009 tools
drwxr-xr-x  2    400  401   4096 Nov 18  2009 wiki
Code:
./configure --with-boost=/usr/local/boost_1_41_0/boost/
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gawk... (cached) gawk
checking for g++... g++
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking whether make sets $(MAKE)... (cached) yes
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking for boostlib >= 1.38.0... configure: error: We could not detect the boost libraries (version 1.38 or higher). If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option.  If you are sure you have boost installed, then check your version number looking in <boost/version.hpp>. See http://randspringer.de/boost for more documentation.
repinementer is offline   Reply With Quote
Old 06-15-2010, 01:36 AM   #25
Utrecht
Junior Member
 
Location: Utrecht

Join Date: Apr 2010
Posts: 4
Default

Did you use bjam to build Boost? You can find instructions here: http://cufflinks.cbcb.umd.edu/tutorial.html

But anyway, this didn't work for me in the end. It would seem that cufflinks doesn't compile properly on a 32 bit system, so I used a MacBook (to run a few tests) and a 64 bit system (to do the actual analysis) instead.
Utrecht is offline   Reply With Quote
Old 06-15-2010, 01:41 AM   #26
repinementer
Member
 
Location: asia

Join Date: Dec 2009
Posts: 80
Default yes 32 bit is not working

yes i used bjam.
yes i agree some thing wrong with 32 bit
seems 64 bit doesnt have any configure file so no need to run the commands??????????

Code:
./configure --prefix=/path/to/cufflinks/install --with-boost=/path/to/boost
make
make install
but ./command (ex: ./cufflinks) are working fine

Quote:
[bogugk@Trivia cufflinks-0.8.2.Linux_x86_64]$ ./cufflinks ./test_data.sam
Counting hits in map
Total map density: 104.000000
Processing bundle [ test_chromosome:52-550 ] with 99 non-redundant alignments

Last edited by repinementer; 06-15-2010 at 01:44 AM. Reason: adding commands
repinementer is offline   Reply With Quote
Old 06-15-2010, 02:03 AM   #27
Utrecht
Junior Member
 
Location: Utrecht

Join Date: Apr 2010
Posts: 4
Default

That's right, there are pre-compiled binaries for 64 bit systems and/or Macs. Much easier, eh? :-)
Utrecht is offline   Reply With Quote
Old 06-15-2010, 02:09 AM   #28
repinementer
Member
 
Location: asia

Join Date: Dec 2009
Posts: 80
Default FluxCapacitor and FluxStimulator

Have you installed these?
Seems pretty google code RNASEQ tools.

http://flux.sammeth.net/cap_installation.html
repinementer is offline   Reply With Quote
Old 10-27-2010, 12:19 PM   #29
emucaki
Member
 
Location: .

Join Date: Apr 2009
Posts: 12
Default

Gonna bump this thread again. I was able to get through all the boost and sam/bam issues for this installation (I've successfully installed bowtie and tophat as well), but now with Cufflinks I'm having a 'make' error (it is a 64 bit system).

Quote:
GList.hh(413): remark #981: operands are evaluated in unspecified order
if (Found(item, result)) return true;
^

compilation aborted for clustering.cpp (code 2)
make[2]: *** [clustering.o] Error 1
make[2]: Leaving directory `/work/emucaki/goblin/Cufflinks/cufflinks-0.9.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/work/emucaki/goblin/Cufflinks/cufflinks-0.9.1'
make: *** [all] Error 2
Any ideas?
emucaki is offline   Reply With Quote
Old 10-27-2010, 01:52 PM   #30
jmarshall
Samtools maintainer
 
Location: Cambridge, UK

Join Date: Jul 2009
Posts: 39
Default

Quote:
Originally Posted by emucaki View Post
GList.hh(413): remark #981: operands are evaluated in unspecified order
You are using Intel's compiler and you have configured cufflinks so as to compile with -Werror.

This is a relatively useless warning, and it's hard to see why it's being triggered by this code. It seems that the usual advice is to switch the warning off: http://software.intel.com/en-us/foru...ad.php?t=62309.
jmarshall is offline   Reply With Quote
Old 10-27-2010, 01:58 PM   #31
emucaki
Member
 
Location: .

Join Date: Apr 2009
Posts: 12
Default

Well that's just one of over a dozen warnings that occur during the make process, I just pasted the last one cause I thought that might be the one triggering the stop.
emucaki is offline   Reply With Quote
Old 07-11-2011, 01:07 PM   #32
hibachings2013
Member
 
Location: na

Join Date: Jun 2010
Posts: 15
Default here got the same error too !

Hi All,

I am trying to install cufflinks btw got the same error too.


checking for python platform... darwin
checking for python script directory... ${prefix}/lib/python2.7/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.7/site-packages
checking for boostlib >= 1.38.0... configure: error: We could not detect the boost libraries (version 1.38 or higher). If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option. If you are sure you have boost installed, then check your version number looking in <boost/version.hpp>. See http://randspringer.de/boost for more documentation.


so i'd specify the path to BOOST_ROOT as xi wang suggested rather than i give the path to boost_1_46_1.
sorry for a newbie question here, how do we know where the BOOST_ROOT is?

Thanks a lot in advance,

Last edited by hibachings2013; 07-11-2011 at 01:09 PM.
hibachings2013 is offline   Reply With Quote
Old 07-25-2011, 09:13 AM   #33
Tiger123
Junior Member
 
Location: Michigan

Join Date: Jul 2011
Posts: 6
Default

Hi Guys,

I am also having configuration problems for cufflinks.

I got the error as below for ./configure

checking for boostlib >= 1.38.0... configure: error: We could not detect the boost libraries (version 1.38 or higher). If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option. If you are sure you have boost installed, then check your version number looking in <boost/version.hpp>. See http://randspringer.de/boost for more documentation.

I installed the latest version of boost. But, my system is 32-bit. I tried to reinstall a 64-bit linux, which I failed in my system. Is there any solution to this problem? Thanks.
Tiger123 is offline   Reply With Quote
Old 07-25-2011, 09:23 AM   #34
Tiger123
Junior Member
 
Location: Michigan

Join Date: Jul 2011
Posts: 6
Default

Some additional information about the results got when I build the boost using:

bjam --prefix=\usr\local --toolset=gcc architecture=x86 address_model=32 link=static runtime-link=static stage install

/home/tiger123/boost/boost_1_47_0/tools/build/v2/build/property.jam:328: in validate1 from module property
error: Invalid property '<address_model>32': unknown feature 'address_model'.
/home/tiger123/boost/boost_1_47_0/tools/build/v2/build/property.jam:337: in property.validate from module property
/home/tiger123/boost/boost_1_47_0/tools/build/v2/build/build-request.jam:216: in convert-command-line-element from module build-request
/home/tiger123/boost/boost_1_47_0/tools/build/v2/build/build-request.jam:153: in build-request.from-command-line from module build-request
/home/tiger123/boost/boost_1_47_0/tools/build/v2/build-system.jam:612: in load from module build-system
/home/tiger123/boost/boost_1_47_0/tools/build/v2/kernel/modules.jam:283: in import from module modules
/home/tiger123/boost/boost_1_47_0/tools/build/v2/kernel/bootstrap.jam:142: in boost-build from module
/home/tiger123/boost/boost_1_47_0/boost-build.jam:17: in module scope from module


Any thoughts?
Tiger123 is offline   Reply With Quote
Old 07-26-2011, 06:00 PM   #35
chenyao
Member
 
Location: Beijing

Join Date: Jul 2011
Posts: 74
Default

Quote:
Originally Posted by Tiger123 View Post
Some additional information about the results got when I build the boost using:

bjam --prefix=\usr\local --toolset=gcc architecture=x86 address_model=32 link=static runtime-link=static stage install

/home/tiger123/boost/boost_1_47_0/tools/build/v2/build/property.jam:328: in validate1 from module property
error: Invalid property '<address_model>32': unknown feature 'address_model'.
/home/tiger123/boost/boost_1_47_0/tools/build/v2/build/property.jam:337: in property.validate from module property
/home/tiger123/boost/boost_1_47_0/tools/build/v2/build/build-request.jam:216: in convert-command-line-element from module build-request
/home/tiger123/boost/boost_1_47_0/tools/build/v2/build/build-request.jam:153: in build-request.from-command-line from module build-request
/home/tiger123/boost/boost_1_47_0/tools/build/v2/build-system.jam:612: in load from module build-system
/home/tiger123/boost/boost_1_47_0/tools/build/v2/kernel/modules.jam:283: in import from module modules
/home/tiger123/boost/boost_1_47_0/tools/build/v2/kernel/bootstrap.jam:142: in boost-build from module
/home/tiger123/boost/boost_1_47_0/boost-build.jam:17: in module scope from module


Any thoughts?

Same problem ,wait for the answer
chenyao is offline   Reply With Quote
Old 07-27-2011, 11:29 AM   #36
Tiger123
Junior Member
 
Location: Michigan

Join Date: Jul 2011
Posts: 6
Default

Hi, solved the problem with the error message (checking for boostlib >= 1.38.0... configure: error: ....) while cufflinks configuration.
Today I installed libboost using;
sudo apt-get install libboost-all-dev.

Then I configured successfully.

./configure --prefix=/usr/local/cufflinks/install --with-boost=/usr/local/boost

The output is below:

-------------------------------------
-----------------------------------

checking for boostlib >= 1.38.0... yes
checking for bamlib... yes
checking build system type... x86_64-unknown-linux-gnu
checking whether the Boost::Thread library is available... yes
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking if zlib is wanted... yes
checking for inflateEnd in -lz... yes
------------------------------------------
---------------------------------------

-- cufflinks 1.0.3 Configuration Results --
C++ compiler: g++ -Wall -Wno-strict-aliasing -g -gdwarf-2 -Wuninitialized -m64 -O3 -DNDEBUG -pthread -I/usr/local/boost/include -I/usr/local/include
GCC version: gcc (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2
Host System type: x86_64-unknown-linux-gnu
Install prefix: /usr/local/cufflinks/install
Install eprefix: ${prefix}

See config.h for further configuration information.
Email <cole@cs.umd.edu> with questions and bug reports.
Tiger123 is offline   Reply With Quote
Old 07-27-2011, 06:15 PM   #37
chenyao
Member
 
Location: Beijing

Join Date: Jul 2011
Posts: 74
Default

Quote:
Originally Posted by Tiger123 View Post
Hi, solved the problem with the error message (checking for boostlib >= 1.38.0... configure: error: ....) while cufflinks configuration.
Today I installed libboost using;
sudo apt-get install libboost-all-dev.

Then I configured successfully.

./configure --prefix=/usr/local/cufflinks/install --with-boost=/usr/local/boost

The output is below:

-------------------------------------
-----------------------------------

checking for boostlib >= 1.38.0... yes
checking for bamlib... yes
checking build system type... x86_64-unknown-linux-gnu
checking whether the Boost::Thread library is available... yes
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking if zlib is wanted... yes
checking for inflateEnd in -lz... yes
------------------------------------------
---------------------------------------

-- cufflinks 1.0.3 Configuration Results --
C++ compiler: g++ -Wall -Wno-strict-aliasing -g -gdwarf-2 -Wuninitialized -m64 -O3 -DNDEBUG -pthread -I/usr/local/boost/include -I/usr/local/include
GCC version: gcc (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2
Host System type: x86_64-unknown-linux-gnu
Install prefix: /usr/local/cufflinks/install
Install eprefix: ${prefix}

See config.h for further configuration information.
Email <cole@cs.umd.edu> with questions and bug reports.

Dear Tiger, using your command, I got the same message. It seems cufflinks has found "boost". But after that, I cannot get the "make" successful, which always showed the error. Did you "make" it?
chenyao is offline   Reply With Quote
Old 07-27-2011, 06:44 PM   #38
chenyao
Member
 
Location: Beijing

Join Date: Jul 2011
Posts: 74
Default

OK , I fix it. It seems the boost is not installed in "/usr/local/boost"
chenyao is offline   Reply With Quote
Old 07-27-2011, 08:05 PM   #39
Tiger123
Junior Member
 
Location: Michigan

Join Date: Jul 2011
Posts: 6
Default

Glad you got it. I installed boost in the /usr/local and exported the path.

make and make install went fine. I was able to run the test_data.sam given in the cufflinks webpage. But, there was one warning. Pasted below is the output.


tiger123@ubuntu:~/data$ cufflinks ./test_data.sam
You are using Cufflinks v1.0.3, which is the most recent release.
[bam_header_read] EOF marker is absent. The input is probably truncated.
[bam_header_read] invalid BAM binary header (this is not a BAM file).
File ./test_data.sam doesn't appear to be a valid BAM file, trying SAM...
[16:48:28] Inspecting reads and determining fragment length distribution.
> Processed 1 loci. [*************************] 100%
Warning: Using default Gaussian distribution due to insufficient paired-end reads in open ranges. It is recommended that correct paramaters (--frag-len-mean and --frag-len-std-dev) be provided.
> Map Properties:
> Total Map Mass: 102.50
> Read Type: 75bp x 75bp
> Fragment Length Distribution: Truncated Gaussian (default)
> Default Mean: 200
> Default Std Dev: 80
[16:48:28] Assembling transcripts and estimating abundances.
> Processed 1 loci.

I am not sure whether this will create problems when running the actual data.
Tiger123 is offline   Reply With Quote
Old 07-27-2011, 08:37 PM   #40
chenyao
Member
 
Location: Beijing

Join Date: Jul 2011
Posts: 74
Default

Quote:
Originally Posted by Tiger123 View Post
Glad you got it. I installed boost in the /usr/local and exported the path.

make and make install went fine. I was able to run the test_data.sam given in the cufflinks webpage. But, there was one warning. Pasted below is the output.


tiger123@ubuntu:~/data$ cufflinks ./test_data.sam
You are using Cufflinks v1.0.3, which is the most recent release.
[bam_header_read] EOF marker is absent. The input is probably truncated.
[bam_header_read] invalid BAM binary header (this is not a BAM file).
File ./test_data.sam doesn't appear to be a valid BAM file, trying SAM...
[16:48:28] Inspecting reads and determining fragment length distribution.
> Processed 1 loci. [*************************] 100%
Warning: Using default Gaussian distribution due to insufficient paired-end reads in open ranges. It is recommended that correct paramaters (--frag-len-mean and --frag-len-std-dev) be provided.
> Map Properties:
> Total Map Mass: 102.50
> Read Type: 75bp x 75bp
> Fragment Length Distribution: Truncated Gaussian (default)
> Default Mean: 200
> Default Std Dev: 80
[16:48:28] Assembling transcripts and estimating abundances.
> Processed 1 loci.

I am not sure whether this will create problems when running the actual data.
Strange. I also run test_data.sam. That's what I got:

Processed 1 loci. [*************************] 100%
Warning: Using default Gaussian distribution due to insufficient paired-end reads in open ranges. It is recommended that correct paramaters (--frag-len-mean and --frag-len-std-dev) be provided.
> Map Properties:
> Total Map Mass: 102.50
> Read Type: 75bp x 75bp
> Fragment Length Distribution: Truncated Gaussian (default)
> Default Mean: 200
> Default Std Dev: 80
[11:34:41] Assembling transcripts and estimating abundances.
> Processing Locus test_chromosome:52-550 [************************ ] 99%段错误
chenyao is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 09:59 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO