SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Epicentre kit & Bioanalyzer result wacguy RNA Sequencing 3 08-27-2013 05:02 AM
Odd behavior using samtools mpileup, bcftools JimC Bioinformatics 7 05-21-2013 11:34 AM
Samtools mpileup generate different SNP result every run? edge Bioinformatics 8 12-20-2012 11:53 AM
how can i interpret the result of mpileup of samtools? dkrtndhkd Bioinformatics 1 08-09-2012 02:28 PM
Odd characters in samtools mpileup output Bueller_007 Bioinformatics 0 08-26-2011 04:33 PM

Reply
 
Thread Tools
Old 05-23-2013, 12:57 PM   #1
afkoeppel
Member
 
Location: VA

Join Date: Jul 2011
Posts: 17
Default mpileup with & without -q: odd result?

Hello everyone,

I'm running mpileup twice on the same BAM alignment of RNASeq reads against the same reference genome, with and without filtering for mapping quality (-q 5 or not), and getting, (I think) an odd result.

I checked the same position on the same chromosome between the filtered and unfiltered output.
In both cases, 7997 reads overlapped that position, but the counts of reads that matched the reference (,.) versus those that were mismatches (Aa) was drastically different between the two. Specifically, there were far more mismatches at that position in the filtered output than in the unfiltered output.

If I'm understanding what -q does correctly, it should simply be disregarding alignments with a mapq score of lower than 5 (if I use -q 5), right? So I would understand if the number of reads overlapping the position was reduced, but I don't understand why the count of overlapping reads would remain the same, but the proportion of matches to mismatches would change.

Can anyone help me make sense of this?

Thanks,
Alex

P.S.
samtools 0.1.18
Linux OS
afkoeppel is offline   Reply With Quote
Old 05-23-2013, 03:17 PM   #2
BAMseek
Senior Member
 
Location: St. Louis, MO, USA

Join Date: Apr 2011
Posts: 124
Default

Samtools has a maximum depth cut-off in order to limit the amount of memory required, which leads to some odd behavior when you hit that max. I think the max is 8,000 and it looks like you are close to that. Try supplying the -d flag with a really large number (like 10 million), and see if the results are more what you expect.

Justin
BAMseek is offline   Reply With Quote
Old 05-30-2013, 07:48 AM   #3
afkoeppel
Member
 
Location: VA

Join Date: Jul 2011
Posts: 17
Default

That seems to have done the trick. Thanks.
afkoeppel is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 01:15 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO