SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
cuffdiff: use merged.gtf from cuffmerge or combined.gtf from cuffcompare? turnersd Bioinformatics 21 10-02-2014 03:41 AM
Cuffmerge output: merged.gtf and transcript.gtf always vary ? Chirag RNA Sequencing 6 01-15-2013 06:20 AM
GFF to GTF, and GTF to GRanges objects lewewoo Bioinformatics 2 04-03-2012 02:52 PM
tophat -G gene model annotations GTF format? silin284 Bioinformatics 15 04-21-2011 06:26 AM
Does Cufflnks accept GFF for annotations? DrD2009 Bioinformatics 0 03-12-2010 08:17 AM

Reply
 
Thread Tools
Old 11-13-2012, 03:55 AM   #1
anna_vt
Junior Member
 
Location: London

Join Date: Jun 2009
Posts: 5
Default Cannot find any mention of reference gff/gtf annotations in cuffmerge output

Hi,

I have been using tophat and cufflinks to analyse some RNA seq data, but cuffmerge is not behaving as I would expect.

For all steps of the analysis I have used a reference gff3 file for RABT.

For tophat I specifed:
Code:
-G <gff file> --transcriptome-index <transcriptome prefix>
and on subsequent usage just
Code:
--transcriptome-index <transcriptome prefix>
For cufflinks I specified
Code:
--GTF-guide <gff file>
All the fpkm_tracking and gtf output files contain annotations from the original gtf file, including from transcripts with very high coverage so not just faux reads.

When using cuffmerge for the 16 samples I use the following command:
Code:
cuffmerge <cufflinks gtf list file> -o cuffmerge -g <gff file> -p 17
In none of the output files is there any mention of the annotations from the gff file.
I thought that the problem was that it is a gff file and not a gtf file, so I converted using
Code:
gffread <gff file> -T -o <gtf file>
Code:
cuffmerge <cufflinks gtf list file> -o cuffmerge -g <gtf file> -p 17
However the output is the same. There is also no mention of the gtf file in the log file for either gff3 or gtf:

Code:
/software/additional/bin/cuffmerge <path>/sam/tophat/cufflinks/gtfFileList.txt -o cuffmerge -g <path>/data/abH97_filt.gffread.gtf -p 17
gtf_to_sam -F <path>/sam/tophat/1_1/cufflinks/transcripts.1_1.gtf ./merged_asm/tmp/gtf2sam_filenEmb9h
gtf_to_sam -F <path>/sam/tophat/1_2/cufflinks/transcripts.1_2.gtf ./merged_asm/tmp/gtf2sam_fileeDtnvd
gtf_to_sam -F <path>/sam/tophat/1307_M5/cufflinks/transcripts.1307_M5.gtf ./merged_asm/tmp/gtf2sam_fileQhIpNd
gtf_to_sam -F <path>/sam/tophat/1_3/cufflinks/transcripts.1_3.gtf ./merged_asm/tmp/gtf2sam_fileAHuzXi
gtf_to_sam -F <path>/sam/tophat/2_1/cufflinks/transcripts.2_1.gtf ./merged_asm/tmp/gtf2sam_fileZw6YGs
gtf_to_sam -F <path>/sam/tophat/2_2/cufflinks/transcripts.2_2.gtf ./merged_asm/tmp/gtf2sam_file87N56G
gtf_to_sam -F <path>/sam/tophat/2_3/cufflinks/transcripts.2_3.gtf ./merged_asm/tmp/gtf2sam_file6ipSj0
gtf_to_sam -F <path>/sam/tophat/A151_M5/cufflinks/transcripts.A151_M5.gtf ./merged_asm/tmp/gtf2sam_file3SWsto
gtf_to_sam -F <path>/sam/tophat/F25_2_1/cufflinks/transcripts.F25_2_1.gtf ./merged_asm/tmp/gtf2sam_fileC2SotR
gtf_to_sam -F <path>/sam/tophat/F25_2_3/cufflinks/transcripts.F25_2_3.gtf ./merged_asm/tmp/gtf2sam_filelpirkp
gtf_to_sam -F <path>/sam/tophat/F25_2_4/cufflinks/transcripts.F25_2_4.gtf ./merged_asm/tmp/gtf2sam_fileJX9sR1
gtf_to_sam -F <path>/sam/tophat/F25_2_M5/cufflinks/transcripts.F25_2_M5.gtf ./merged_asm/tmp/gtf2sam_filezkS48I
gtf_to_sam -F <path>/sam/tophat/F25_2_M6/cufflinks/transcripts.F25_2_M6.gtf ./merged_asm/tmp/gtf2sam_file68Mb8u
gtf_to_sam -F <path>/sam/tophat/I142_4/cufflinks/transcripts.I142_4.gtf ./merged_asm/tmp/gtf2sam_file6CwbQl
gtf_to_sam -F <path>/sam/tophat/I142_M10/cufflinks/transcripts.I142_M10.gtf ./merged_asm/tmp/gtf2sam_fileeikjVg
gtf_to_sam -F <path>/sam/tophat/I142_M9/cufflinks/transcripts.I142_M9.gtf ./merged_asm/tmp/gtf2sam_filetTRVKg
sort -k 3,3 -k 4,4n --temporary-directory=./merged_asm//meta_asm_tmp/ ./merged_asm/tmp/gtf2sam_filenEmb9h ./merged_asm/tmp/gtf2sam_fileeDtnvd ./merged_asm/tmp/gtf2sam_fileQhIpNd ./merged_asm/tmp/gtf2sam_fileAHuzXi ./merged_asm/tmp/gtf2sam_fileZw6YGs ./merged_asm/tmp/gtf2sam_file87N56G ./merged_asm/tmp/gtf2sam_file6ipSj0 ./merged_asm/tmp/gtf2sam_file3SWsto ./merged_asm/tmp/gtf2sam_fileC2SotR ./merged_asm/tmp/gtf2sam_filelpirkp ./merged_asm/tmp/gtf2sam_fileJX9sR1 ./merged_asm/tmp/gtf2sam_filezkS48I ./merged_asm/tmp/gtf2sam_file68Mb8u ./merged_asm/tmp/gtf2sam_file6CwbQl ./merged_asm/tmp/gtf2sam_fileeikjVg ./merged_asm/tmp/gtf2sam_filetTRVKg > ./merged_asm/tmp/mergeSam_file1gh4tl
cufflinks -o ./merged_asm/ -F 0.05 -q --overhang-tolerance 200 --library-type=transfrags -A 0.0 --min-frags-per-transfrag 0 --no-5-extend -p 1 ./merged_asm/tmp/mergeSam_file1gh4tl
cuffcompare -o tmp_meta_asm -C -G  ./merged_asm//transcripts.gtf
cuffcompare -o tmp_meta_asm -C -G  ./merged_asm//merged.gtf
And nothing is prefixed / goes to the folder cuffmerge that i specifed with the -o flag, it only goes to the merged_asm folder.

Can anyone tell me what I am doing wrong or if this behaviour is as expected?
Version is: cufflinks v2.0.2

Many Thanks
Anna
anna_vt is offline   Reply With Quote
Reply

Tags
cufflinks 2.0.2, cuffmerge, gff, gff3, gtf

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 10:22 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO