SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
FastX-toolkit liu_xt005 Bioinformatics 13 10-11-2014 04:52 AM
vmware is installed but not working vinila86 Bioinformatics 3 02-03-2012 04:15 AM
Fastx collapsed frymor Bioinformatics 0 02-10-2011 01:36 AM
fastx quality score madsaan Bioinformatics 2 01-12-2011 08:55 AM
fastx newbie madsaan Bioinformatics 0 01-10-2011 10:03 AM

Reply
 
Thread Tools
Old 04-12-2011, 11:18 PM   #1
Seta
Member
 
Location: Europe

Join Date: Mar 2011
Posts: 14
Default Getting FASTX installed

Hello,

I'm new to sequence analysis and I have barcoded Illumina sequences which I want to split into different files. I already tried to install FASTX to do this, but I get constantly the next error when I want to configure:

checking for GTEXTUTILS... configure: error: Package requirements (gtextutils) were not met:

No package 'gtextutils' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTEXTUTILS_CFLAGS
and GTEXTUTILS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I've followed the instructions on the http://hannonlab.cshl.edu/fastx_tool...nfig_email.txt mail, but that doen't work.
So what are GTEXTUTILS and how can I solve this problem? Is there otherwise anyother program that I can use to split barcoded sequences?

Thanks
Seta is offline   Reply With Quote
Old 05-25-2011, 12:47 AM   #2
blackjimmy
Junior Member
 
Location: shanghai

Join Date: Mar 2009
Posts: 4
Default

You need to look at the installation man page at:
http://hannonlab.cshl.edu/fastx_tool...all_centos.txt

following the instructions.
blackjimmy is offline   Reply With Quote
Old 05-26-2011, 05:40 AM   #3
brentp
Member
 
Location: denver, co

Join Date: Apr 2010
Posts: 72
Default

I use this if you dont have pkg-config, you'll have to set the environment variables they describe in the help.

Code:
# fastx for read trimming.
FASTX_VERSION=0.0.13
mkdir -p fastx && cd fastx
wget http://hannonlab.cshl.edu/fastx_tool...ls-0.6.tar.bz2
bunzip2 libgtextutils-0.6.tar.bz2 && tar xvf libgtextutils-0.6.tar
cd libgtextutils-0.6 && ./configure && make && sudo make install && sudo ldconfig
cd ../
sudo apt-get install pkg-config && sudo pkg-config
wget http://hannonlab.cshl.edu/fastx_toolkit/fastx_toolkit-${FASTX_VERSION}.tar.bz2
bunzip2 fastx_toolkit-${FASTX_VERSION}.tar.bz2
tar xvf fastx_toolkit-${FASTX_VERSION}.tar
cd fastx_toolkit-${FASTX_VERSION} && ./configure && make && sudo make install
brentp is offline   Reply With Quote
Old 05-24-2017, 08:52 AM   #4
zillur
Senior Member
 
Location: Puerto Rico

Join Date: Sep 2014
Posts: 106
Default Having the same problem, trying to resolve in different ways but noting working

Hi there,
I was trying to install this tool in my centos7 workstation but having problem. I tried to google and also tried all the possible solution but nothing works. I tried the code by "brentp" but getting the following error. code:
PHP Code:
# fastx for read trimming.
FASTX_VERSION=0.0.13
mkdir 
-p fastx && cd fastx
wget http
://hannonlab.cshl.edu/fastx_tool...ls-0.6.tar.bz2
bunzip2 libgtextutils-0.6.tar.bz2 && tar xvf libgtextutils-0.6.tar
cd libgtextutils
-0.6 && ./configure && make && sudo make install && sudo ldconfig 
...
... 
Whenever I try sudo make install it gave me:
Code:
ter.c  -fPIC -DPIC -o .libs/pipe_fitter.o
pipe_fitter.c: In function ‘pipe_close’:
pipe_fitter.c:30:6: error: variable ‘i’ set but not used [-Werror=unused-but-set-variable]
  int i, status ;
      ^
cc1: all warnings being treated as errors
make[3]: *** [pipe_fitter.lo] Error 1
make[3]: Leaving directory `/gondor/zillur/tools/fastx/libgtextutils-0.6/src/gtextutils'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/gondor/zillur/tools/fastx/libgtextutils-0.6/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/gondor/zillur/tools/fastx/libgtextutils-0.6'
make: *** [all] Error 2
I also tried the instructions here:
PHP Code:
http://hannonlab.cshl.edu/fastx_toolkit/install_centos.txt 
but its not working.
Is there any solution there??
Thanks in advance.

Best regards
Zillur
zillur is offline   Reply With Quote
Old 05-24-2017, 09:44 AM   #5
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,978
Default

There are likely more current/better alternatives to fastx. What exactly you need from fastx package?

BTW: The errors you posted are not very informative with all "warnings" being treated as errors.
GenoMax is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 01:29 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO