SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
error when installing GAPipeline-1.5.0 in ubuntu amd64 sanzi Bioinformatics 5 01-17-2014 11:31 AM
cufflinks error harshinamdar Bioinformatics 1 03-02-2012 10:51 AM
error installing GATK dkrtndhkd Bioinformatics 0 02-03-2012 05:48 PM
error in installing Newbler 2.5.3 shuang Bioinformatics 6 10-26-2011 03:17 AM
the make error for installing cufflinks sflong RNA Sequencing 3 10-18-2011 07:04 PM

Reply
 
Thread Tools
Old 12-02-2010, 06:34 AM   #1
plantae
Junior Member
 
Location: china

Join Date: Dec 2010
Posts: 7
Default error while installing cufflinks 9.x

hi, all,
cufflinks version 0.8.3 works fine on my current system. try to update it,
i have download the latest version of cufflinks v0.9.3, however, i failed to run the program on my cluster / failed to compile it.

The x86_64 binary file can be execute directly, however, when i used it on a remote node (the running environment is linux cluster). ERRORS are:

./cufflinks: /lib64/libz.so.1: no version information available (required by ./cufflinks)
cufflinks v0.9.3

Due to this error, i try to compile cufflinks locally:
The setting for the configuration is like:

./configure --prefix=/home/myuser/cufflinks/ --with-boost=/home/myuser/mylib/boost --with-bam=/home/myuser/mylib

the boost version is 1.45
and the structure of the /home/myuser/mylib directory is:
mylib/lib/libbam.a
mylib/include/bam/*.h

The configuration process if fined, however, in compiling phase:
...
bundles.h:546: warning: comparison between signed and unsigned integer expressions
g++ -Wall -Wno-strict-aliasing -g -gdwarf-2 -Wuninitialized -m64 -O3 -DNDEBUG -pthread -I/home/SCE/jiangwenkai/mylib/boost/include -I/
home/SCE/jiangwenkai/mylib/include -o cufflinks -L/home/SCE/jiangwenkai/mylib/boost/lib -L/home/SCE/jiangwenkai/mylib/lib cufflinks.o
libcufflinks.a libgc.a -lboost_thread -lbam -lz
/home/SCE/jiangwenkai/mylib/lib/libbam.a(bam_import.o): In function `__bam_get_lines':
/home/SCE/jiangwenkai/samtools-0.1.11/bam_import.c:76: undefined reference to `gzopen64'
/home/SCE/jiangwenkai/mylib/lib/libbam.a(bam_import.o): In function `sam_open':
/home/SCE/jiangwenkai/samtools-0.1.11/bam_import.c:442: undefined reference to `gzopen64'
/home/SCE/jiangwenkai/mylib/lib/libbam.a(bam_import.o): In function `sam_header_read2':
/home/SCE/jiangwenkai/samtools-0.1.11/bam_import.c:126: undefined reference to `gzopen64'
collect2: ld returned 1 exit status
make[2]: *** [cufflinks] Error 1
make[2]: Leaving directory `/home/SCE/jiangwenkai/RNA_seq/cufflinks-0.9.3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/SCE/jiangwenkai/RNA_seq/cufflinks-0.9.3'
make: *** [all] Error 2

I have google for this error, someone says that "undefined reference to `gzopen64'" error is caused by zlib settings, our system wide zlib library position is like this:

ll /usr/local/lib |grep 'libz.'
-rw-r--r-- 1 root root 135786 2010-11-08 15:34 libz.a
lrwxrwxrwx 1 root root 13 2010-11-08 15:34 libz.so -> libz.so.1.2.5
lrwxrwxrwx 1 root root 13 2010-11-08 15:34 libz.so.1 -> libz.so.1.2.5
-rwxr-xr-x 1 root root 108533 2010-11-08 15:34 libz.so.1.2.5

ll /usr/lib |grep 'libz.'
lrwxrwxrwx 1 root root 6 2009-10-13 12:16 libgz.a -> libz.a
lrwxrwxrwx 1 root root 14 2009-10-13 12:16 libgz.so.1 -> /lib/libz.so.1
-rw-r--r-- 1 root root 87624 2006-06-16 20:02 libz.a
lrwxrwxrwx 1 root root 13 2010-12-02 22:32 libz.so -> libz.so.1.2.5
lrwxrwxrwx 1 root root 13 2010-12-02 22:32 libz.so.1 -> libz.so.1.2.5
lrwxrwxrwx 1 root root 10 2009-10-13 12:16 libz.so.1-20101202 -> libgz.so.1
-rwxr-xr-x 1 root root 108533 2010-11-08 15:34 libz.so.1.2.5
lrwxrwxrwx 1 root root 14 2009-10-13 12:16 libz.so-20101202 -> /lib/libz.so.1

objdump -T /usr/local/lib/libz.so.1.2.5 | grep gzopen64
000061e0 g DF .text 00000014 ZLIB_1.2.3.3 gzopen64
objdump -T /usr/lib/libz.so.1.2.5 | grep gzopen64
000061e0 g DF .text 00000014 ZLIB_1.2.3.3 gzopen64

I have try with --with-zlib=/usr/local/ --with-zlib=/usr/local/lib --with-zlib=/usr --with-zlib=/usr/lib --without-zlib, none of these opinions works, all go to the same error.

does anyone know what is the problem?
best
regards!
plantae is offline   Reply With Quote
Reply

Tags
cufflinks samtools

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 04:42 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO