Go Back   SEQanswers > Bioinformatics > Bioinformatics

Similar Threads
Thread Thread Starter Forum Replies Last Post
VarScan2 copynumber option error curious2 Bioinformatics 10 02-11-2016 04:46 AM
varscan2 mpileup2snp output differs from mpileup output JohanF Bioinformatics 0 02-28-2014 02:47 AM
varscan2: copynumber detection mrfox Bioinformatics 2 07-10-2013 01:07 PM
VarScan2 somatic output (genotype call) desmo Bioinformatics 1 12-27-2012 08:49 AM
too many indels output by varscan2 mrfox Bioinformatics 2 09-25-2012 09:17 AM

Thread Tools
Old 08-25-2015, 01:23 PM   #1
Junior Member
Location: Toronto, ON

Join Date: Mar 2013
Posts: 1
Default VarScan2 copynumber output name

Hi. I have been running VarScan2 copynumber
according to the manual's instructions, shown here:
samtools mpileup -q 1 -f ref.fa normal.bam tumor.bam |
java -jar VarScan.jar copynumber varScan --mpileup 1
This will create a single output file, varScan.copynumber, containing the raw copynumber calls.
My exact command is:
samtools mpileup -B -q 10 -f genome.fa normal.bam tumor.bam |\
awk -F"\t" '$4 > 0 && $7 >0' | java -jar $varscan_dir/VarScan.jar copynumber \
tumor.copynumber --mpileup 1 --data-ratio 0.50
The problem is that it is not writing the output to my file "tumor.copynumber" but instead to "output.copynumber" which is the default. Anyone have any idea why?
nstickle is offline   Reply With Quote
Old 01-30-2018, 04:43 PM   #2
Junior Member
Location: Los Angeles

Join Date: Oct 2015
Posts: 1
Default Facing same issue

Did you figure out a solution for this?

I tried this:


samtools mpileup -q 1 -B -f ${ref_fasta} ${normalbam} ${tumorbam} |java -jar ${varscan} copynumber --mpileup ${outputname} 1

This seems working, though in VarScan2 copynumber page it is mentioned:

samtools mpileup -q 1 -f ref.fa normal.bam tumor.bam |
java -jar VarScan.jar copynumber <outputname> --mpileup 1

Which is not working!


$ samtools --version
samtools 1.5
Using htslib 1.5
Copyright (C) 2017 Genome Research Ltd.

VarScan v2.3

Last edited by amalthomas111; 01-30-2018 at 05:39 PM.
amalthomas111 is offline   Reply With Quote
Old 08-29-2018, 07:21 AM   #3
Junior Member
Location: Barcelona

Join Date: Aug 2018
Posts: 1
Default Order matters apparently

I had the same problem and apparently solved by putting the name of the output file just after the combined pileup file and before the "--mpileup 1" argument

java -jar VarScan.v2.3.9.jar copynumber tumor_normal.mpileup OUTPUTNAME --mpileup 1 --min-coverage 10 (etc etc if you want to add other options)

The output of this command should be OUTPUTNAME.copynumber (the .copynumber is always added by Varscan).

Hope it helps!
kasadevall is offline   Reply With Quote


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -8. The time now is 05:37 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO