SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
MEGAN example files ClemBuntu Bioinformatics 1 10-31-2015 06:13 PM
Megan SEED/KEGG question msteffe1 Bioinformatics 11 02-09-2015 08:15 PM
Mg-rast --> megan ewilbanks Metagenomics 5 12-06-2014 05:08 PM
MEGAN annotation morning latte Bioinformatics 2 08-02-2014 10:03 AM
MEGAN - how the heck? kga1978 Bioinformatics 1 02-06-2012 04:03 AM

Reply
 
Thread Tools
Old 07-25-2017, 09:25 AM   #1
AncientGenomes
Junior Member
 
Location: Southwest US

Join Date: Jul 2017
Posts: 1
Default MALT/MEGAN question

Hello all,

I'm trying to use MALT/MEGAN for the first time through ubuntu. I have a FASTA file of some shotgun microbial sequences that I converted from an Illumina HiSeq FASTQ output and I'm trying it to run these through the examples in the MALT manual locally on my machine. MALT is properly installed universally, as is MEGAN.

Here's my command line for malt-build:

malt-build -i ./Viral_Reference/viral.1.1.genomic.fna.gz -d index -a2taxonomy ./nucl_acc2tax-May2017.abin -s DNA

I then did the following:
malt-run -i 05C_test.fasta -d ./index -m BlastN -o .

it says it's coming back with 10,440 queries, 11 aligned queries and 22 num. alignments. This all seemed to work fine and produced the necessary tree and mapping files.

after doing this in the command line:
MEGAN -g -f ./05C_test.rma6 -E

I'm getting the following:

Executing: load treeFile='ncbi.tre';
Loading mapping file: ncbi.map
Reading file: ncbi.map: 1266115
Loading taxonomy file: ncbi.tre
Reading file: ncbi.tre: 1266115
Executing: open file='./05C_test.rma6';
Alert - Open file failed: java.io.IOException: File has unknown type: ./05C_test.rma6

It seems this is an issue with the rm6 output format. My java is up to date-1.8.0_131. I don't think it is an input problem either.

One additional question:
I can't seem to use -f to get an output of Tab or Text. it's giving me a kickback the -f and --format are not functional. is this a problem other users have experienced?

Thank you very much,
AG

UPDATE 7/26/17:
Looks like this is an issue with Ubuntu version of MEGAN not being compatible with .rma6 extension files. I opened the file just fine on the Windows 64bit version of MEGAN. I've alerted the developers about this issue.

Anyone else using MALT here?

Last edited by AncientGenomes; 07-26-2017 at 10:27 AM. Reason: Compatibility issue identified
AncientGenomes is offline   Reply With Quote
Old 11-03-2017, 04:06 PM   #2
mbravo
Junior Member
 
Location: Mexico

Join Date: Nov 2017
Posts: 1
Default different problem

Hi,
Im using MALT for the first time too and I have some doubts about building the index.
My command line for malt-build is :

malt-build -i /mnt/Archives/BLAST_databases/nt/*.* -d Index -a2taxonomy /mnt/Cromosoma/mavila/mbravo/malt/data/gi_taxid-March2015X.bin --sequenceType DNA

It creates the following files:
index0.idx ref.idx table0.db table0.idx

but they`re empty.

I will appreciate any comment.
mbravo is offline   Reply With Quote
Reply

Tags
blast, malt, malt-build, malt-run, megan

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 11:23 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO