SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Inner distance value for TopHat / Proper mapping with RNA-Seq PE data ocs Bioinformatics 6 11-27-2011 11:10 AM
tophat -r mate inner distance option ssseq Bioinformatics 2 01-10-2011 06:15 AM
Tophat mean inner distance error for SOLID data repinementer Bioinformatics 0 10-28-2010 07:58 PM
distance measure to compare peak set profiles in chip-seq datasets avilella Bioinformatics 0 03-18-2010 03:01 AM
tophat -r mate inner distance mgogol RNA Sequencing 0 09-11-2009 02:41 PM

Reply
 
Thread Tools
Old 04-28-2010, 01:51 PM   #1
xhuister
Member
 
Location: China

Join Date: Apr 2010
Posts: 41
Default TopHat Error: you must set the mean inner distance between mates with -r?

I tried to use TOPHAT on Arabidopsis mRNA-seqs, they are not pair end reads. I've run the example data you provided, so the installation is all right.
For my own data, I've built bowtie index "tair9_bwt" for Arabidopsis genome sequences. I have 6 fastq files of mRNA-seqs. I want to use TOPHAT to find new transcript boundaries in intergenic regions.

I used the following command to test two of the six fq files, it could generate the 3 output files successfully.
tophat ~/bowtie-0.12.5/tair9_bwt/tair9_bwt tail.fastq,test1.fastq

But when I tried to use options like -i -I or -G or other options, it failed:
-----------------------
$ tophat ~/bowtie-0.12.5/tair9_bwt/tair9_bwt tail.fastq,test1.fastq -i 30 -I 15000
Error: you must set the mean inner distance between mates with -r
Traceback (most recent call last):
File "/home/wux3/mrnaseq/tophat/bin/tophat", line 1635, in ?
sys.exit(main())
File "/home/wux3/mrnaseq/tophat/bin/tophat", line 1535, in main
exit(1)
TypeError: 'str' object is not callable
----------------------

The description of -r option is:
-r/--mate-inner-dist <int> This is the expected (mean) inner distance between mate pairs. For, example, for paired end runs with fragments selected at 300bp, where each end is 50bp, you should set -r to be 200. There is no default, and this parameter is required for paired end runs.

But the mRNA-seqs I have are not paired end, anybody knows how to set this option on my data? And, why the "-r" option is not neccessary when no options used in the commandline?

Thank you in advance.
xhuister is offline   Reply With Quote
Old 04-28-2010, 02:03 PM   #2
xhuister
Member
 
Location: China

Join Date: Apr 2010
Posts: 41
Default

Now, it is OK. Just used options before the fastq... -.-

tophat -G TAIR9_GFF3_tophat -i 30 -I 15000 ~/bowtie-0.12.5/tair9_bwt/tair9_bwt tail.fastq,head.fastq

Last edited by xhuister; 04-28-2010 at 02:08 PM.
xhuister is offline   Reply With Quote
Old 02-24-2011, 09:07 AM   #3
maximilianh
Member
 
Location: UK

Join Date: Oct 2009
Posts: 15
Default

thanks for posting this, just saved me a lot of frustrations...
maximilianh is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 12:08 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO