SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
CIGAR string from BWA-SW output incorrect ? robs Bioinformatics 13 01-13-2012 04:07 AM
Bowtie Exec format error. Wrong Architecture. tboothby Bioinformatics 2 12-01-2011 11:25 AM
interpreting the CIGAR in the SAM format efoss Bioinformatics 2 10-29-2011 10:04 AM
BWA generating incorrect CIGAR string? foxyg Bioinformatics 6 09-16-2011 11:22 AM
generate CIGAR string from 2 sequences? bbimber Bioinformatics 0 03-20-2010 09:44 AM

Reply
 
Thread Tools
Old 01-19-2011, 12:46 PM   #1
genome
Junior Member
 
Location: new zealand

Join Date: Nov 2010
Posts: 3
Default bowtie - invalid CIGAR string - wrong sam format

Hi,

I am trying to align short reads from Illumina with different aligners.

I have used the same .fq files to align with BWA, Bowtie and Maq.

BWA and Maq align without errors and give me the expected output files in the right format.

But when I use the same fq and reference files to align with Bowtie, I get the following:

My Command:

bowtie --chunkmbs 100 -p 2 -X 500 prefixDB -1 /path/to/file/file_1.fq -2 /path/to/file/file_2.fq result.sam

Result:

# reads processed: xxx
# reads with at least one reported alignment: yyy (57.06%)
# reads that failed to align: zzz (42.94%)
Reported aaa paired-end alignments to 1 output stream(s)

So that looks alright, but when I tried converting the resultant sam file to bam:

samtools view -bS -o result.bam result.sam

I get:

[samopen] no @SQ lines in the header.
[sam_read1] missing header? Abort!

So I indexted the reference.fasta file and tried:

samtools view -bt ref.fasta.fai result.sam > result.bam

I get:

[sam_header_read2] 1 sequences loaded.
Parse error at line 1: invalid CIGAR character
Aborted

Now this is the first line of result.sam (the file I am trying to convert to bam)

SRR034509.174/1 + NC_000913.2 1272036 GCACCACAGGCGTCGCCTATCGACTGCCAGAAGAGACGCTGGAGCAGGAACTAACCCTGTTGTGGAAGCGAGAGATGATTAATGGCTGTGTTTGTTTATCA IIII;III>-8II*II.IIIIII@II@:I.IIIIII567II?EI);>>DI,I?H0&7F8AB=*&.;F5';E.(0)2,?,44%$)%!&%#$&"$#$##%!#" 0 81:C>A,82:C>T,89:T>G,90:A>T,92:C>T,93:T>G,94:G>T,95:C>T,96:C>T,98:A>T,100:C>A

All lines follow the same format, which I realize doesn't look the a typical .sam file format (it has missing fields) and I am wondering where I have gone wrong, and how I can correct this.

Things to note:

- I am running the latest bowtie and samtools version
- My bowtie-build command on the reference.fasta has given me the right files as I have used them to align other .fq reads.
- As mentioned previously, BWA and Maq worked fine with the same data so its very likely nothing is wrong with that.

Thanks
genome is offline   Reply With Quote
Old 01-19-2011, 09:17 PM   #2
swbarnes2
Senior Member
 
Location: San Diego

Join Date: May 2008
Posts: 912
Default

That's not a .sam file. It's Bowtie native format. You need to add -S or --sam to the command line make the output .sam format.

The "+" is the giveaway. SAM output has the bitwise flag, which is a number, in the second column of the output.
swbarnes2 is offline   Reply With Quote
Old 02-16-2011, 01:36 PM   #3
genome
Junior Member
 
Location: new zealand

Join Date: Nov 2010
Posts: 3
Default

Quote:
Originally Posted by swbarnes2 View Post
That's not a .sam file. It's Bowtie native format. You need to add -S or --sam to the command line make the output .sam format.

The "+" is the giveaway. SAM output has the bitwise flag, which is a number, in the second column of the output.
:P thanku!
genome is offline   Reply With Quote
Reply

Tags
bowtie, cigar, sam bam

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 04:14 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO