SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install Bowtie gene_x Bioinformatics 172 08-13-2015 09:58 AM
how to install and use Picard cliff Bioinformatics 15 05-16-2015 06:02 AM
CASAVA 1.7 Install Help aligenie Bioinformatics 29 05-23-2014 02:58 AM
BFAST - Install Adamo Bioinformatics 4 06-08-2010 12:02 AM
Install TopHat knoto Bioinformatics 0 11-05-2009 02:46 AM

Reply
 
Thread Tools
Old 01-12-2011, 11:59 AM   #1
skblazer
Member
 
Location: Massachusetts

Join Date: Feb 2009
Posts: 50
Default How to install ALLPATHLG?

I have used two days to try building it, but I have not fixed it.

When I tried the latest version, it failed when ./configure

Code:
g++ version is >= 4.3.3... yes
./configure: line 14507: AC_PROG_GREP: command not found
checking for Boost headers version >= 103800... /share/bin/boost_1_43_0//include/boost-1_43
checking for Boost's header version... 1_43
checking for the toolset name used by Boost for g++... gcc43 -gcc
./configure: line 15248: syntax error near unexpected token `re-using'
./configure: line 15248: `  _AS_ECHO_LOG(re-using the existing conftest.$ac_objext)'
But I can't find any information about how to fix the problem

Then I tried an earlier version, it failed either when ./configure
It told me my compiler doesn't support OpenMP
Code:
checking for the Boost filesystem library... yes
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... no
checking whether pthreads work with -Kthread... no
checking whether pthreads work with -kthread... no
checking for the pthreads library -llthread... no
checking whether pthreads work with -pthread... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... no
checking validity of OpenMP configuation.... Failed...
configure: Configure failed with the error message: Your compiler must support OpenMP.
It either doesn't work when I add the flag --disable-openmp with the same report.

But I checked my gcc version, and found that gmp was installed in my system and my gcc should support gmp.
Code:
gcc -v
Using built-in specs.
Target: x86_64-unknown-linux-gnu
Configured with: ../gcc-4.3.3/./configure --prefix=/share/bin/gcc-4.3.3 --with-gmp=/share/bin/gmp-4.2.4/ --with-mpfr=/share/bin/mpfr-2.3.2/ --disable-multilib --enable-languages=c,c++,fortran,objc
Thread model: posix
gcc version 4.3.3 (GCC)
So I have no idea how to fix it.

Anybody can share some information?
skblazer is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 03:12 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO