SEQanswers

Go Back   SEQanswers > Applications Forums > RNA Sequencing



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with TopHat v1.4.0 luigra Bioinformatics 2 01-31-2012 11:57 PM
Tophat Installation problems sebastion Bioinformatics 0 01-10-2012 08:14 AM
other problems with tophat 1.1.3 zorph Bioinformatics 0 11-16-2010 01:38 PM
Problems using TopHat output in SAMtools nat Bioinformatics 1 09-01-2009 11:13 AM
Tophat 1.0.7 problems jwaage Bioinformatics 4 05-25-2009 09:28 AM

Reply
 
Thread Tools
Old 01-24-2012, 06:01 AM   #1
luigra
Junior Member
 
Location: Rome

Join Date: Jan 2012
Posts: 7
Default Problems with TopHat v1.4.0

Dear all I'm trying to use the last version of tophat (v1.4.0) by using the -GTF flag (the reads are mapped before on transcripts). What exactly I'm running is:

ophat --output-dir=<$Output_dir> --mate-inner-dist=30 --mate-std-dev=20 --min-anchor-length=5 --num-threads=8 --closure-search --keep-tmp --GTF=<$transcriptome_file> --transcriptome-index=<$Out_index> <$Index_File> <$R1_Fast> <$R2_Fast>

Obviously the $ items are replaced by the real names

The programs seems to work for more than nine hours but after the point "Searching for junctions via segment mapping" it stopped with the following error:

Traceback (most recent call last):
File "/work/ahc/grassi/Shared_Programs/tophat-1.4.0/src/tophat", line 3063, in ?
sys.exit(main())
File "/work/ahc/grassi/Shared_Programs/tophat-1.4.0/src/tophat", line 3029, in main
user_supplied_deletions)
File "/work/ahc/grassi/Shared_Programs/tophat-1.4.0/src/tophat", line 2681, in spliced_alignment
[maps[initial_reads[left_reads]].unspliced_bwt, maps[initial_reads[left_reads]].seg_maps[-1]],
TypeError: list indices must be integers


am I doing something wrong or alternatively it is a program problem?

Thanks in advance
luigi
__________________
Luigi Grassi
UniversitÓ degli Studi di Roma La Sapienza
Dipartimento di Fisica
Piazzale Aldo Moro 5, 00185 Roma
luigra is offline   Reply With Quote
Old 02-16-2012, 04:11 AM   #2
jstolt
Junior Member
 
Location: Philadelphia, PA

Join Date: Feb 2012
Posts: 3
Default A similar problem with TopHat

I am having a similar problem aligning reads using TopHat (v1.4.1). Specificially, I am attempting to align ~62 million paired-end reads generated from an Illumina HiSeq2000 and processed using CASAVA 1.8. TopHat is run with the following options:

tophat -o ./tophat_out -r 50 -a 6 -i 30 -I 15000 -p 4 --closure-search --coverage-search --microexon-search <index_base> <reads1_1[,...,readsN_1]> <[reads1_2,...readsN_2]>

Please note: <index_base> is replaced by the location of the indexes; <reads1_1[,...,readsN_1]> is replaced with 16 .gz read1 files; and, <[reads1_2,...readsN_2]> is replaced with the matching 16 .gz read2 files in the same order. Both of these lists of read files are comma separated without spaces.

This runs for about five hours and the following error is returned:

Searching for junctions via segment mapping
Traceback (most recent call last):
File "/usr/local/tophat-1.4.1.Linux_x86_64/tophat", line 3063, in <module> sys.exit(main())
File "/usr/local/tophat-1.4.1.Linux_x86_64/tophat", line 3029, in main user_supplied_deletions)
File "/usr/local/tophat-1.4.1.Linux_x86_64/tophat", line 2682, in spliced_alignment
[maps[initial_reads[left_reads]].unspliced_bwt, maps[initial_reads[left_reads]].seg_maps[-1]],
TypeError: list indices must be integers, not str

I have used this set of indexes previously to align reads with TopHat without difficulty. Is this an error on my part or is there an error with TopHat?

My apologies for any SEQanswers community faux pas - this is my first post.

Thanks for your assistance!
jstolt is offline   Reply With Quote
Old 02-16-2012, 04:34 AM   #3
luigra
Junior Member
 
Location: Rome

Join Date: Jan 2012
Posts: 7
Default --closure-search problem

Hi,
I think that this error is due to the --closure-search option, indeed when I removed it I did not receive any error.

Best
luigi
__________________
Luigi Grassi
UniversitÓ degli Studi di Roma La Sapienza
Dipartimento di Fisica
Piazzale Aldo Moro 5, 00185 Roma
luigra is offline   Reply With Quote
Old 02-16-2012, 05:41 AM   #4
jstolt
Junior Member
 
Location: Philadelphia, PA

Join Date: Feb 2012
Posts: 3
Default

Luigi,

Thanks for your expeditious reply! Indeed, I tried removing the "--closure-search" option and now things are running fine.

Cheers!

Jonathan
jstolt is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 05:02 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.