SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to get a gtf file for cufflinks camelbbs Bioinformatics 9 07-07-2019 05:30 AM
Any Available uniform cufflinks masking file Bardj RNA Sequencing 1 08-18-2013 10:13 AM
Best source for GTF file for use with TopHat/Cufflinks sdarko Bioinformatics 17 12-14-2012 11:48 AM
cufflinks won't read my GTF file moriah Bioinformatics 0 08-28-2011 12:31 AM
Cufflinks GTF file ECHo Bioinformatics 0 02-15-2010 02:59 AM

Reply
 
Thread Tools
Old 05-06-2013, 01:11 PM   #1
rflrob
Member
 
Location: Berkeley, CA

Join Date: May 2010
Posts: 50
Default Cufflinks not masking features in the mask GTF file?

Hi all,
I'm running cufflinks with the mask option:
Code:
   cufflinks --num-threads 50 --output-dir analysis-multi/CaS3A -u -M Reference/AAA/suspect.gtf  --frag-bias-correct Reference/AAA/mel_only.fa  -G Reference/AAA/mel_only.gtf analysis-multi/CaS3A/assigned_dmel_rescued.bam
but I still end up with, for instance, relatively high (and variable) FPKMs in mitochondrial genes, which should be filtered out from the reads.

Code:
$ grep mt:tRNA:K mel_only.gtf
dmel_dmel_mitochondrion_genome	FlyBase	exon	3768	3838	.	+	.	transcript_id "FBtr0100864"; gene_id "FBgn0013697"; gene_name "mt:tRNA:K";
$ grep mt:tRNA:K suspect.gtf
dmel_dmel_mitochondrion_genome	FlyBase	exon	3768	3838	.	+	.	transcript_id "FBtr0100864"; gene_id "FBgn0013697"; gene_name "mt:tRNA:K";
I did find an old, essentially un-answered post on this forum mentioning a similar issue; anyone have any other deep insight?
rflrob is offline   Reply With Quote
Old 05-06-2013, 03:53 PM   #2
pengchy
Senior Member
 
Location: China

Join Date: Feb 2009
Posts: 116
Default

I have compared the speed of running with " -M -g " parameters and without them.
The "without" group only lasted 3-5 hours, but the "with" group have been running 48 hours without any output.
pengchy is offline   Reply With Quote
Old 10-13-2013, 01:40 PM   #3
sschavan
Junior Member
 
Location: USA

Join Date: Oct 2012
Posts: 7
Default cufflinks masking option for mitochondrial genes

Hi all,

I have a similar problem, I tried using the cufflinks masking option for mitochondrial genes using the below command:

cufflinks --mask-file=/illumina/genomes/Homo_sapiens/Ensembl/GRCh37/Annotation/Genes/mask_MR.gtf -o . -p 6 -g /illumina/genomes/Homo_sapiens/Ensembl/GRCh37/Annotation/Genes/genes.gtf -u ../tophat_HS034/accepted_hits.bam

In the resultant cufflinks output file, genes.fpkm_tracking and isoforms.fpkm_tracking I see that the MT were still present so I couldn't get the masking option to work

I also tried both -g / -G , didn't work for them too. I wasn't sure if I am doing something incorrectly.

I was wondering if there is anyone who could get masking option to work and could provide any guidance, that would be highly appreciated.

Thanks
Shweta
sschavan is offline   Reply With Quote
Old 03-17-2014, 02:48 AM   #4
sindrle
Senior Member
 
Location: Norway

Join Date: Aug 2013
Posts: 266
Default

Can I ask how you created this file?

/illumina/genomes/Homo_sapiens/Ensembl/GRCh37/Annotation/Genes/mask_MR.gtf
sindrle is offline   Reply With Quote
Old 03-17-2014, 11:29 AM   #5
sschavan
Junior Member
 
Location: USA

Join Date: Oct 2012
Posts: 7
Default

I just 'awk' the lines having Chromosome column value as "MT" from the genes.gtf file to get a subset of mitochondrial entries. I obtained a subset from the Ensembl gtf file, which had "MT" as Chromosome in the column1.

awk -F "\t" '$1=="MT"{print }' < genes.gtf > mask_MR.gtf

Shweta
sschavan is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 08:20 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO