SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bowtie: Ultrafast and memory-efficient alignment of short reads to the human genome Ben Langmead Literature Watch 2 03-04-2013 03:06 AM
The best short read aligner Deutsche Bioinformatics 4 04-14-2011 08:12 PM
Short Read Micro re-Aligner Paper nilshomer Literature Watch 0 10-29-2010 10:59 AM
New Short Read Aligner sparks Bioinformatics 48 08-26-2009 09:01 AM
Very Short Read aligner Rupinder Bioinformatics 1 06-02-2009 08:10 PM

Reply
 
Thread Tools
Old 07-20-2010, 01:16 AM   #381
Xi Wang
Senior Member
 
Location: MDC, Berlin, Germany

Join Date: Oct 2009
Posts: 316
Default

Quote:
Originally Posted by sdvie View Post
Dear all,

I am quite intrigued with Bowtie and the options it offers.
When trying to figure out the best settings for my application, the following question arose:

According to the manual, the --best and --strata options do not apply when aligning paired-end reads. So how can I sort the valid alignments that are produced and - if I want to output only one alignment/read - how do I make sure that it is the "best" one?

using the -m 1 -v 2 options, I would only output one (any?) read that has up to 2 mm, right?
alternatively, using -m 1 -n 0 , I could be more stringent setting lower -l and -e values, but still, I would not have a ranking in the "--best" sense?

Many thanks for your comments!
Sophia
I think it's hard for bowtie to combine best single end alignment. Also it's hard to define the best alignment for paired-end reads.
__________________
Xi Wang
Xi Wang is offline   Reply With Quote
Old 07-20-2010, 06:17 AM   #382
sdvie
Member
 
Location: Spain

Join Date: Jul 2010
Posts: 68
Default best alignment for paired-end reads

Quote:
Originally Posted by Xi Wang View Post
I think it's hard for bowtie to combine best single end alignment. Also it's hard to define the best alignment for paired-end reads.
Thanks for the comment. I realized that I actually made a mistake asking my question with the indicated parameters, since '-m 1' automatically reduces the output to reads with "unique" alignments, meaning that there is no sorting necessary.
The question would rather be if I use the '-a' all alignment output option, whether then there would be a possibility to sort the achieved alignments.

cheers,
Sophia
sdvie is offline   Reply With Quote
Old 07-20-2010, 12:30 PM   #383
axiom7
Member
 
Location: Southwest

Join Date: Aug 2009
Posts: 14
Default More on disparate results between -a vs -m1

Hi again,

Have not gotten any reply to my posting, so I thought I'd make it a little easier for you. I am pasting the --12, 10-line input file and the two commands which quickly and easily reproduce my (perhaps perceived) problem. Again, the reference sequence is human chromosome 1.

Here are the two commands (assuming the --12 file is named x.12.fa and that the reference index is named hschr1):

bowtie -t -f --ff -I700 -X1300 -v0 -y -m1 hschr1 --12 x.12.fa
bowtie -t -f --ff -I700 -X1300 -v0 -y -a hschr1 --12 x.12.fa

And here is x.12.fa:

>0000000000 GAAGCTGAGGTGGGAGGATC IIIIIIIIIIIIIIIIIIII GCTAGGCGTGGTGGCTGGGA IIIIIIIIIIIIIIIIIIII
>0000000001 CCTGGTTCCTGGCACAGAGC IIIIIIIIIIIIIIIIIIII AGGCTGGTCTCAAACTCCTG IIIIIIIIIIIIIIIIIIII
>0000000002 GGAATTTTGTTCTTGCTCAT IIIIIIIIIIIIIIIIIIII GAGCAGTTAAAACAGTTGCT IIIIIIIIIIIIIIIIIIII
>0000000003 CCATAATATCTAGCCTGTAG IIIIIIIIIIIIIIIIIIII AACTACTGAAAAATTTTGAA IIIIIIIIIIIIIIIIIIII
>0000000004 GAACTCATCATTTTTTATGG IIIIIIIIIIIIIIIIIIII CATTGCTTTTGTCCCACCGA IIIIIIIIIIIIIIIIIIII
>0000000005 ATTCATATTGCTACTGAAAT IIIIIIIIIIIIIIIIIIII AGTCCATGAGTGCAGGGAAA IIIIIIIIIIIIIIIIIIII
>0000000006 AGAAAAGGCCAAACTCTGGA IIIIIIIIIIIIIIIIIIII AAAAAAAAGAAGAAGAAGAG IIIIIIIIIIIIIIIIIIII
>0000000007 GATGAAGACCACAGCATCAA IIIIIIIIIIIIIIIIIIII CATGTGTCTGCGCCTGCGCC IIIIIIIIIIIIIIIIIIII
>0000000008 ATGGTTCTTAGCTAGATTCA IIIIIIIIIIIIIIIIIIII GTTGTGTATATTTATCTCTT IIIIIIIIIIIIIIIIIIII
>0000000009 AGCTGAAAAATGGTTGAACC IIIIIIIIIIIIIIIIIIII TGGCTATGTGGGCTCTTTTT IIIIIIIIIIIIIIIIIIII

Thanks.
Susan


Quote:
Originally Posted by axiom7 View Post
Hi,

I have some paired end data generated from human chromosome 1. Pairs are between 700 and 1300 bases apart. I have cut 10 pairs from the overall data to run some tests to try and understand what bowtie is doing, as the researcher is really only interested in unique pairs.

When I run bowtie with -m1 --ff -v0 -y parameters, bowtie reports that there are 7 reads with at least one reported alignment, 1 read failed to align, and 2 reads were suppressed due to -m. The reads that align are numbers 1,3,4,5,7,8,9.

However when I run bowtie with -a --ff -v0 -y, bowtie reports that all 10 reads align and in addition, it shows multiple alignments for reads 1 and 8.

Two things don't make sense to me:

1. Why does bowtie say that one read does not align at all when I specify -m1 and then report alignments for all 10 pairs when I specify -a?

2. Why does bowtie report reads for pairs 1 and 8 for the -m1 run, when it shows multiple alignments for those pairs when I specify -a?

Of course all runs specify -I700 -X1300.

Thanks.
Susan
axiom7 is offline   Reply With Quote
Old 07-22-2010, 05:14 AM   #384
genetic
Junior Member
 
Location: Europe

Join Date: Jul 2010
Posts: 2
Default Dummy question

Dear all,

I have tried running bowtie for the first time. I run it with the following parameters: ./bowtie -t -3 5 -p 8 hg19 reads/my_reads_file.txt hg19.map

However after the program has finished calculating, I do not see the output file. A second puzzling thing is that it writes to the screen that only ~1% of my reads mapped to the genome. Do you have any ideas what is wrong?

Thank you!
genetic is offline   Reply With Quote
Old 07-27-2010, 07:05 AM   #385
axiom7
Member
 
Location: Southwest

Join Date: Aug 2009
Posts: 14
Red face More on disparate results between -a vs -m1

Hi all,
I thought I asked a reasonable question...
Susan
axiom7 is offline   Reply With Quote
Old 07-27-2010, 07:34 AM   #386
sdvie
Member
 
Location: Spain

Join Date: Jul 2010
Posts: 68
Default

Quote:
Originally Posted by axiom7 View Post
Hi all,
I thought I asked a reasonable question...
Susan
Hi Susan,

I am still a beginner in using Bowtie, but here go some suggestions and comments:

1. The x.12.fa is your input file, right? Have you tried to separate the two reads of the pairs into two separate files and then run the mapping? Why are you pasting the input sequences here, I thought you had doubts about the alignment results?

2. Have you tried each of these reads separately, lets say with the -a option?

Quote:
Originally Posted by axiom7 View Post
When I run bowtie with -m1 --ff -v0 -y parameters, bowtie reports that there are 7 reads with at least one reported alignment, 1 read failed to align, and 2 reads were suppressed due to -m.
3. As far as I understand, -m1 only reports reads with exactly one alignment, not at least one alignment.
sdvie is offline   Reply With Quote
Old 07-27-2010, 01:10 PM   #387
axiom7
Member
 
Location: Southwest

Join Date: Aug 2009
Posts: 14
Default Regarding the disparate -m1 vs -a

Thanks for a reply,

I posted the input reads so that someone could run bowtie using that input against human chromosome #1 and see the results for themselves, as it is so small and easily done.

I HAVE run the same input using two input fasta files and the results are identical. Easier to post the contents of the --12 file.

bowtie output tells you how many reads were "suppressed" due to the -m setting so the fact that pairs 1, 8 show up with -m1 and then show up multiple alignments with -a is not expected behavior as I understand it.

It's a good idea to run each pair by itself. I'll try that and see if it enlightens me further.

Thanks again.
Susan
axiom7 is offline   Reply With Quote
Old 08-05-2010, 05:57 AM   #388
dcfargo
Member
 
Location: Chapel Hill

Join Date: Aug 2008
Posts: 22
Default

Please help with genome reseq parameter suggestion for PE 100mer data (D. melanogaster)

What are people going with as the 'default' alignment parameters/workflow?

I'm wondering if people are using -x and if so what value? Is it better to allow for structural variations with a large -x value or to even leave it out?

Is using -m1 and --max part of the workflow?

Also what combination of -l/-n/-e do people find works well with PE 100mers? Obviously it depends on data quality.
dcfargo is offline   Reply With Quote
Old 08-17-2010, 02:28 PM   #389
kweber2
Member
 
Location: Seattle, WA

Join Date: Aug 2010
Posts: 10
Default

Can anyone tell me what this warning means? I can't find any documentation for it:

"Warning: Exhausted best-first chunk memory for read IPAR1:1:11:15296:1878:1#0/1 (patid 2434682); skipping read"

Thanks for any help!

-Kris
kweber2 is offline   Reply With Quote
Old 08-20-2010, 08:21 AM   #390
edchen
Junior Member
 
Location: NY

Join Date: Aug 2010
Posts: 1
Default

I'm running Bowtie for the first time and I keep getting:

Out of memory allocating the ebwt[] array for the Bowtie index. Please try
again on a computer with more memory.

I'm using the hg19 index and am running on a 32-bit system with 4 GB of memory. I've tried to reduce the memory usage with offrate, but it doesn't seem to help.

I've even gone so far as to boot into safe mode to use the command prompt with low memory use, and I don't see bowtie allocate anymore than 890 MB of memory.

Last edited by edchen; 08-20-2010 at 09:14 AM.
edchen is offline   Reply With Quote
Old 08-20-2010, 08:44 AM   #391
malcook
Member
 
Location: 66206

Join Date: Sep 2009
Posts: 22
Default Warning: Exhausted best-first chunk memory for read

when I get this message I have found that the following option makes it go away (doubling the default value)

--chunkmbs 128
malcook is offline   Reply With Quote
Old 08-25-2010, 12:46 PM   #392
david2
Member
 
Location: Switzerland

Join Date: May 2010
Posts: 19
Default Out of memory with me as well

Hi,
I am also getting:
C:\bowtie-0.12.5>bowtie -c hg18 ATTCAGTAGGTACTATAAATGGCCGAT --chunkmbs 512
Out of memory allocating the ebwt[] array for the Bowtie index. Please try
again on a computer with more memory.
Command: bowtie -c --chunkmbs 512 hg18 ATTCAGTAGGTACTATAAATGGCCGAT

I tried the chunkmbs with 32, 128, 256 and 512 on a winXP32bit with 4GB of RAM, the maximum allocated memory is around 1.2 GB. Any other ideas I could try?
Thanks a lot,

David

--edit--:
I rebooted the system, the task manager shows at least 3.6G of total phys. memory, 2.7GB available and 1.6G cache, I am still getting the request to use a 'computer with more memory'. I thought Bowtie was supposed to run on the human genome with ~ 2GB of RAM?
--edit2--:
I got it to work under a VMWare virtual machine running Ubuntu on the above XP system, without any chunkmbs setting, there is definitely something fishy when running under XP

Last edited by david2; 08-26-2010 at 01:06 PM. Reason: Added more info about the system... works under VMWare/Ubuntu
david2 is offline   Reply With Quote
Old 10-06-2010, 01:21 PM   #393
seqniru
Junior Member
 
Location: MA

Join Date: Oct 2010
Posts: 5
Default

Hi,
I am just starting to use Linux and Bowtie so this might be something simple.
I downloaded Bowtie and just wanted to run the example suggested in the tutorial.
I am giving the command
chmod ugo+rwx bowtie e_coli reads/e_coli_1000.fq
I get an error that says chmod cannot access e_coli No such file or directory.
Can't figure out what is wrong.
Help appreciated!
Thanks.
seqniru is offline   Reply With Quote
Old 10-06-2010, 03:19 PM   #394
mrawlins
Member
 
Location: Retirement - Not working with bioinformatics anymore.

Join Date: Apr 2010
Posts: 63
Default

The command

chmod ugo+rwx bowtie e_coli reads/e_coli_1000.fq

will change permissions (chmod)
for the user, group and others (ugo)
to include reading, writing and executing permissions (+rwx)
for the files bowtie, e_coli and reads/e_coli_1000.fq

The error is that it can't find a file or directory named e_coli. That will be relative to the directory you are running the command from, so you should try
ls
and see if there are any files named e_coli.

If your filename has a space in it (not recommended) you should be able to put a \ before the space, which should keep the command from thinking you're listing a new file. You could also put the filename with a space in single or double quotes, which may help that same problem.

Hope that helps.
mrawlins is offline   Reply With Quote
Old 10-07-2010, 07:17 AM   #395
seqniru
Junior Member
 
Location: MA

Join Date: Oct 2010
Posts: 5
Default

Thank you mrawlins.
That was very helpful. I finally got bowtie up and running.
seqniru is offline   Reply With Quote
Old 10-08-2010, 07:16 AM   #396
seqniru
Junior Member
 
Location: MA

Join Date: Oct 2010
Posts: 5
Default

Hi All,
Still trying to figure out Bowtie options.
How do I get it to align reads allowing more than 3 mismatches?
Thanks.
seqniru is offline   Reply With Quote
Old 10-08-2010, 08:06 AM   #397
gzentner
Junior Member
 
Location: Cleveland, OH, USA

Join Date: Jun 2010
Posts: 5
Default

seqniru,

You might try -v <int>. This ignores quality values and allows up to <int> mismatches. I don't think there's a limit on it, like with -n only going up to 3 mismatches

I also have a question of my own. I am trying to align some data using Bowtie and keep getting an error:

Reads file contained a pattern with more than 1024 quality values.
Please truncate reads and quality values and and re-run Bowtie
terminate called after throwing an instance of 'int'
Aborted

I have looked for solutions to this and tried some but nothing seems to work. My reads and quality strings are the same length, -v does not work.

Here is a file head:

@IL2_1423:1:49:708:540
GTCTCTTTCTTTTAGATGAA
+
>>>>>>>>>>>>>>>>>>>>

I am not sure if this has something to do with the quality string being all >? Any help is appreciated! Thanks.
gzentner is offline   Reply With Quote
Old 10-08-2010, 10:01 AM   #398
seqniru
Junior Member
 
Location: MA

Join Date: Oct 2010
Posts: 5
Default

Thank you gzentner.
I tried -v but it does not work with number greater than 3 either.
seqniru is offline   Reply With Quote
Old 10-12-2010, 09:47 AM   #399
seqniru
Junior Member
 
Location: MA

Join Date: Oct 2010
Posts: 5
Default

Still looking for answer to this question.
How do I get it to align reads allowing more than 3 mismatches?
Both -n and -v can only be set to a maximum of 3 mismatches.
Thanks.
seqniru is offline   Reply With Quote
Old 10-12-2010, 10:24 AM   #400
Chipper
Senior Member
 
Location: Sweden

Join Date: Mar 2008
Posts: 290
Default

-n 3 allows more mismatches if seed length is less than read length. For more mismatches in the seed you need another aligner like Bfast.
Chipper is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 08:51 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.