SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie questions regarding Illumina read quality statistics using FASTX toolkit Lspoor Bioinformatics 21 09-05-2013 11:48 AM
Fastx Toolkit for Quality Stats of data from new illumina pipeline software vedbar Bioinformatics 6 09-19-2011 09:50 AM
SCS/RTA upgrade Q-score of 41 fastx toolkit crash seqfast Bioinformatics 1 08-22-2011 07:15 AM
fastx quality score madsaan Bioinformatics 2 01-12-2011 08:55 AM
FastX Quality Score format kbushley Illumina/Solexa 1 09-05-2010 01:56 AM

Reply
 
Thread Tools
Old 10-29-2010, 01:16 PM   #1
thinkRNA
Member
 
Location: Carlsbad,CA

Join Date: Jan 2010
Posts: 94
Default FASTX-Toolkit: quality score value

I get an error when I use FASTX-Toolkit : Please let me know how to get Fastx to work?

./bin/fastx_clipper -a "ATCTCGTATGCCGTCTTCTGCTTGAAAAAAAAAA" -l 5 -k -o test.out -i test.fastq
fastx_clipper: Invalid quality score value (char '#' ord 35 quality value -29) on line 4

this is the test.fastq
@GA6_00012:6:1:5480:933#0/1
NCTGGGCACTGGGGTGCTGTGGGCAGATATGGGCTACAGAACAAGGAAAGACCCTGGTCCCGGAAGGTGCCAGCTG
+
#,,[email protected]@[email protected]@[email protected]@@@@@@@(''%%'()'(@@@@@@@@@@@@@@@@@@[email protected]#####################
thinkRNA is offline   Reply With Quote
Old 10-29-2010, 11:49 PM   #2
simonandrews
Simon Andrews
 
Location: Babraham Inst, Cambridge, UK

Join Date: May 2009
Posts: 869
Default

There was another thread very recently which covered this. You need to add the -Q33 parameter to tell it that you're using Illumina encoded quality scores, not Sanger encoding.
simonandrews is offline   Reply With Quote
Old 10-30-2010, 05:52 AM   #3
maubp
Peter (Biopython etc)
 
Location: Dundee, Scotland, UK

Join Date: Jul 2009
Posts: 1,539
Default

Quote:
Originally Posted by simonandrews View Post
There was another thread very recently which covered this. You need to add the -Q33 parameter to tell it that you're using Illumina encoded quality scores, not Sanger encoding.
The other way round

It assumes Illumina (ASCII offset 64), but you have Sanger (offset 33), hence -Q33

See: http://seqanswers.com/forums/showthread.php?t=7399
maubp is offline   Reply With Quote
Old 08-23-2011, 11:39 AM   #4
mgogol
Senior Member
 
Location: Kansas City

Join Date: Mar 2008
Posts: 193
Default

Just a note, with Casava 1.8, qualities are switched to offset of 33 in illumina fastq files. So to use these with fastx toolkit, you'll also have to use the -Q33 flag.
mgogol is offline   Reply With Quote
Old 09-30-2014, 01:30 AM   #5
Nanu
Member
 
Location: New Delhi

Join Date: Sep 2014
Posts: 30
Default

When I am running the command fastq to fasta format through Fastx toolkit..It was showing the following error in 64 bit computer on Linux.
fastq_to_fasta: Invalid quality score value (char '(' ord 40 quality value -24) on line 8

Now please give the solution for this problem.
Nanu is offline   Reply With Quote
Old 09-30-2014, 01:41 AM   #6
Nanu
Member
 
Location: New Delhi

Join Date: Sep 2014
Posts: 30
Default

When I am running the command for fastq trimmer in fastx toolkit..it was showing the error :

fastx_trimmer: Invalid quality score value (char '(' ord 40 quality value -24) on line 8

Please suggest the solution to resolve this issue.
Nanu is offline   Reply With Quote
Old 09-30-2014, 01:47 AM   #7
maubp
Peter (Biopython etc)
 
Location: Dundee, Scotland, UK

Join Date: Jul 2009
Posts: 1,539
Default

What was the command you ran Nanu, and did you use the -Q33 flag?
maubp is offline   Reply With Quote
Old 09-30-2014, 01:57 AM   #8
Nanu
Member
 
Location: New Delhi

Join Date: Sep 2014
Posts: 30
Default

I ran :
./fastx_trimmer -t 30 -i <filename> -o <filename2>
No I didnt use any flag.
I am new for this..so please guide me how to use -Q33 flag.
Nanu is offline   Reply With Quote
Old 09-30-2014, 01:59 AM   #9
Nanu
Member
 
Location: New Delhi

Join Date: Sep 2014
Posts: 30
Default

I ran :
./fastx_trimmer -t 30 -i <filename> -o <filename2>

fastq_to_fasta -h -r -v -i <filename.fastq> -o <filename.fasta>

No I didnt use any flag.
I am new for this..so please guide me how to use -Q33 flag.
Nanu is offline   Reply With Quote
Old 09-30-2014, 02:20 AM   #10
maubp
Peter (Biopython etc)
 
Location: Dundee, Scotland, UK

Join Date: Jul 2009
Posts: 1,539
Default

With the fastx tool kit you must add -Q33 to the command to tell it to use the Sanger FASTQ encoding (with quality score offset of 33). Unfortunately some tools default to the now obsolete Illumina encoding (which used an offset of 64), see http://en.wikipedia.org/wiki/FASTQ_format and http://dx.doi.org/10.1093%2Fnar%2Fgkp1137
maubp is offline   Reply With Quote
Old 09-30-2014, 02:39 AM   #11
Nanu
Member
 
Location: New Delhi

Join Date: Sep 2014
Posts: 30
Default

I have Illumina Seq data
Data format:

@HWI-1KL139:40:C0BW5ACXX:1:1102:19408:132180 1:N:0:
TGAACGGACTGGAAACACTGGTCATAATCATGGTGGCGAATAAGTACGCGTTCTTGCAAATCACCAGAAGGCGGTTCCTG
AATGAATGGGAAGCCTTCAAG
+
BCCFFFFDFHGHFIIJJJJJJIIIJGIJJGIJJ?GIHHGHIEGGFHIJJJJGHGHHFFFFFFEEEADDDDDBDB5<?CDD
DDDDCCEDDDDDB<ACDDCCC
@HWI-1KL139:40:C0BW5ACXX:1:1102:19487:132183 1:N:0:
CTGATTCTGAACAGCTTCTTGGGAAGTAGCGACAGCTTGGTTTTTAGTGAGTTGTTCCATTCTTTAGCTCCTAGACCTTT
AGCAGCAAGGTCCATATCTGA
+
@[email protected][email protected]@@FBEHIIGD:[email protected][email protected];?=AEFFCBDDED
3>[email protected](;;:>>>CD>[email protected]
@HWI-1KL139:40:C0BW5ACXX:1:1102:19280:132183 1:N:0:
GACTTCACGCCAGAATACGAAAGACCAGGTATATGCACAAAATGAGATGCTTGCTTATCAACAGAAGGAGTCTACTGCTC
GCGTTGCGTCTATTATGGAAA
+
CCCFFFFFHHHHHJJJJJJIIJJJJJJJJFHIIJJIJJJJJJJJJJIJJJJJGIIJJJJGGGJJJJJHHHHEEDFFFFDE
DDDDDDDDBDDDEEEEDCACD

Where I have to mention it???
Nanu is offline   Reply With Quote
Old 09-30-2014, 02:52 AM   #12
maubp
Peter (Biopython etc)
 
Location: Dundee, Scotland, UK

Join Date: Jul 2009
Posts: 1,539
Default

From the read naming convention, your Illumina data is using the standard "Sanger" FASTQ encoding.
maubp is offline   Reply With Quote
Old 09-30-2014, 05:56 AM   #13
mgogol
Senior Member
 
Location: Kansas City

Join Date: Mar 2008
Posts: 193
Default

Just add it as an argument. I wish this was better documented.

./fastx_trimmer -Q33 -t 30 -i <filename> -o <filename2>

I don't know if this one needs it as well?
fastq_to_fasta -Q33 -h -r -v -i <filename.fastq> -o <filename.fasta>
mgogol is offline   Reply With Quote
Old 09-30-2014, 09:25 AM   #14
Brian Bushnell
Super Moderator
 
Location: Walnut Creek, CA

Join Date: Jan 2014
Posts: 2,669
Default

You might want to try Reformat. It automatically detects quality encoding (though you can override it), is much faster than fastx, does a better job of quality-trimming, and does fastq-to-fasta conversion in the same time as quality-trimming. And it keeps paired reads together.
Brian Bushnell is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 04:07 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO